trying to get started

trying to get started

Postby Jan » Sat 18 Dec 2004 08:55

I downloaded MyDac for Delphi 9 (Net) and got this:

[Fatal Error] E2202 Required package 'dcldac90' not found

What did I mis?
Jan
 
Posts: 23
Joined: Wed 01 Dec 2004 15:54

Postby Jan » Sun 19 Dec 2004 12:45

A project (webmodule) contains nothing more than a MyConnection.
On "if MyConnection1.Connected then response.content:='connected'
else response.content:='not connected';" I get (IE) a beep and a time-out error. Nothing happens!

I'm using Delphi 2005 and MyDac.
Jan
 
Posts: 23
Joined: Wed 01 Dec 2004 15:54

Re: trying to get started

Postby Ikar » Mon 20 Dec 2004 09:42

Please check at the registry HKEY_CURRENT_USER\Software\Borland\BDS\3.0\Known Packages

Or try to reinstall MyDAC.
Ikar
 
Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Postby Jan » Mon 20 Dec 2004 14:29

what is there to check? Corelab is mentioned.....
Jan
 
Posts: 23
Joined: Wed 01 Dec 2004 15:54

Postby Jan » Mon 20 Dec 2004 19:05

Reinstalling does not save the problem. Any idea?
Jan
 
Posts: 23
Joined: Wed 01 Dec 2004 15:54

Postby Ikar » Tue 21 Dec 2004 09:56

Try to copy this file to the folder Windows/System32
Ikar
 
Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Postby Jan » Mon 27 Dec 2004 14:40

I am sorry, but no this does not help.
Without MySQL the program is working fine.
With MyConnection and MyQuery the problem occurs.
After removing both program will not work again.
Jan
 
Posts: 23
Joined: Wed 01 Dec 2004 15:54

Postby Ikar » Tue 28 Dec 2004 09:08

Do you have the error at the time of compilation?

Try to compile MyDAC Demo\Win32\Pictures.
Ikar
 
Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Postby Jan » Tue 28 Dec 2004 14:43

no, no error is displayed.

MyDAC Demo\Win32\Pictures is compiled ok, and running. But my program will still not.
Jan
 
Posts: 23
Joined: Wed 01 Dec 2004 15:54

Postby Ikar » Tue 28 Dec 2004 16:13

Try to search for a link on 'dcldac' or 'dclmydac' in files of your project.
Also you can try to shorten your project up to minimal.
Ikar
 
Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Postby Jan » Thu 30 Dec 2004 09:11

The project is nothing more than MyConnection and 1 MyQuery, but it still won't work. :(
Jan
 
Posts: 23
Joined: Wed 01 Dec 2004 15:54

Postby Ikar » Thu 30 Dec 2004 13:56

Try to search not only in pas-files but in files of project (.bdsproj etc) also.
Ikar
 
Posts: 1693
Joined: Thu 28 Oct 2004 13:56


Return to MySQL Data Access Components