Connecting & gateway is gone..

Connecting & gateway is gone..

Postby GEswin » Sun 14 Nov 2004 21:07

Hi, I setup most networks the same, as far as I know i'm correct in this. I assign each PC a IP in the range of 192.168.1.*, mask 255.255.255.0 .The ADSL router is also one of these IP's (For example 192.168.1.100) and the mysql linux server is another IP in the same range (For example 192.168.1.200). All PC's i set the DNS's to the ones the provider has, and as gateway the IP of the router. When I load my application it connects extremly fast, but it the router is down (disconnected) it takes about a minute, is this a normal behaviour, or something wrong in my settings because it looks like it first trys to find the server trought the ASDL Router, and afterwards locally, while the IP is a local range ?
GEswin
 
Posts: 186
Joined: Wed 03 Nov 2004 16:57
Location: Spain

Re: Connecting & gateway is gone..

Postby Ikar » Mon 15 Nov 2004 15:43

Usually MySQL quickly determines that the server to which to connect
is inaccessible. Suppose, you should ask this question to developers of MySQL Server or gurus in Windows Sockets.
Ikar
 
Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Postby Guest » Mon 15 Nov 2004 20:55

When u shot down the gateway you also disable dns lookups which slow down the process.
here http://dev.mysql.com/doc/mysql/en/DNS.html you can read how mysql use dns and how to disable dns lookups.

Adem.
Guest
 

Postby GEswin » Wed 17 Nov 2004 23:21

Hi Adem, this seems to be the problem i'm having.. Tomorrow I'll try this out.
GEswin
 
Posts: 186
Joined: Wed 03 Nov 2004 16:57
Location: Spain


Return to MySQL Data Access Components