Problem sending data back into Zoho

Problem sending data back into Zoho

Postby JohnM » Fri 16 Dec 2016 16:54

Hello all,
First post.

I have installed the ODBC driver and now able to pull over all the Zoho tables and data. I'm now in the process of writing information back into Zoho via a product call Alpha Anywhere and using the Devart ODBC driver.
I connect to Zoho fine however, when sending the update I receive the following error:
[Devart][ODBC][Zoho CRM]Object 'Accounts' does not have field 'Account_Name'

I know the error is telling me the field does not match Zoho. Can any tell me the field name structure? I match what came out of Zoho and thought it would work.

My code:
sqlUpdateStatement = <<%txt%
UPDATE Accounts SET Account_Name = :New__Account_Name
%txt%
JohnM
 
Posts: 1
Joined: Fri 16 Dec 2016 16:46

Re: Problem sending data back into Zoho

Postby MaximG » Mon 19 Dec 2016 10:31

In our test environment the Accounts table has the field named «Account Name». Try to change your query in the following way:
Code: Select all
UPDATE Accounts SET «Account Name» = :New__Account_Name
MaximG
Devart Team
 
Posts: 738
Joined: Mon 06 Jul 2015 11:34

Re: Problem sending data back into Zoho

Postby alsinger » Sat 07 Jan 2017 12:54

Hi All, JohnM,

My first post as well ...

JohnM, I am making contact as a fellow Alpha Anywhere developer, but hasten to add, unfortunately, I do not have any solutions for your issue.

Well done to you for getting as far as you have..Unfortunately, I am stuck with getting my Alpha Anywhere app to read the tables -

This is the connection string that Alpha generates for me

{A5API='ODBC',DataSource='DevartZohoDriver',A5Syntax='ODBC',A5ODBCTableList=Y,UserName='name@domain.com'}

Any assistance getting past this block much appreciated

Error message is https://drive.google.com/a/alansinger.com/file/d/0B77hYD90aaOyNUJpRkZvbEZ4aG8/view?usp=sharing
alsinger
 
Posts: 2
Joined: Sat 07 Jan 2017 02:50

Re: Problem sending data back into Zoho

Postby MaximG » Tue 10 Jan 2017 14:49

Please describe the detailed steps, which cause the described error in the Alpha Anywhere environment. If we correctly understand, the error occurs when you try to introduce changes to table "Accounts"?
MaximG
Devart Team
 
Posts: 738
Joined: Mon 06 Jul 2015 11:34

Re: Problem sending data back into Zoho

Postby alsinger » Fri 13 Jan 2017 08:37

Hi Maxim,

My initial issue, as described in my first forum post, was due to the fact that I was following documentation on ZOHO CRM (and the DEVART DRIVER) that was out of date in respect of how to access and generate the authentication Token with the effect that I was not in fact using a valid authentication token in the driver configuration

Yesterday my time (Thursday 12th Jan) Devart support helped me out on showing me how the ZOHO interface is now very different to the current documentation and how I could navigate to the place where the authentication token could be generated - which I subsequently did and used in re-configuring the DEVART ZOHOCRM ODBC driver.

What I had been using (incorrectly) was the Zoho ZSC key. :shock:

But now having moved beyond that "blockage", I have been able to read records, and update records :D but once an initial action has been completed (or in the case of an insert, after the submit button for the input is clicked) , my program goes unresponsive -
This si strue for trying to display a second page of records, making a change to a record or inserting a record - the first operation is successful but control is not returned to the user and instead, the program becomes unresponsive.

SO, I have sent all the details to the development platform company for them to review - as well as a detailed message to DEVART support (to Alex)
alsinger
 
Posts: 2
Joined: Sat 07 Jan 2017 02:50

Re: Problem sending data back into Zoho

Postby MaximG » Mon 03 Apr 2017 08:32

Please send all the prepared information on this issue via the e-support form ( https://www.devart.com menu "Support"\"Request Support" ) again. We are preparing to release a new build of our driver and will try to investigate and solve this problem in this release.
MaximG
Devart Team
 
Posts: 738
Joined: Mon 06 Jul 2015 11:34


Return to ODBC Drivers