Entity Developer resets IdGenerator property value

Entity Developer resets IdGenerator property value

Postby Luthfi » Sun 11 Jan 2015 13:39

I am using Entity Developer version 5.7.469 trial version. And I just noticed a strange behavior. Actually it's not just strange but also creating error.

Upon loading existing file, IdGenerator property of all classes in my model file will be reset into Custom. I previously set them into Increment. This bug causes the subsequent code generations produce invalid code. So currently I have to go to each of the classes and set them back to Increment manually before generating code.

Example of correct code (a little part related with IdGenerator value):
Code: Select all
  [Table('dbo.CH_Client')]
  [Model('SedeaDataModel')]
  [Key('FClientId')]
  TChangeClient = class(TMappedEntity)
  private
    [Column('ClientID')]
    [Generator(gtTable, gfOnInsert)]
    FClientId: Integer;


and this is what was generated after closing the model file and reopen it.
Code: Select all
  [Table('dbo.CH_Client')]
  [Model('SedeaDataModel')]
  [Key('FClientId')]
  TChangeClient = class(TMappedEntity)
  private
    [Column('ClientID')]
    [Generator(gtCustom, gfOnInsert)]
    FClientId: Integer;


Is this really a bug, of am i just overlooked something?
Luthfi
 
Posts: 6
Joined: Fri 09 Jan 2015 13:39

Re: Entity Developer resets IdGenerator property value

Postby AlexP » Mon 12 Jan 2015 09:30

Hello,

Thank you for the sample. We have reproduced the described case and will investigate the reason for such behavior. We will inform you as soon as we have any results.
AlexP
Devart Team
 
Posts: 5530
Joined: Tue 10 Aug 2010 11:35


Return to EntityDAC