Advice to "dotConnect for XXX" users

Advice to "dotConnect for XXX" users

Postby gwihen » Thu 14 Aug 2014 20:19

If you have installed dotConnect for Oracle (a Devart product) - or dotConnect for SQLite on your computer, EntityDeveloper for EntityDAC will not work "as is",
when selecting "Database First" in the "Create Model Wizard" process.
The program will display a message error telling you that 'InvariantName' must be unique, that 'Devart.Data.Oracle' is already present. This error is located in configuration file
EntityDeveloper.exe.Config.

Here is the explanation. When you install "dotConnect for Oracle" in your system, DataProvider with InvariantName 'Devart.Data.Oracle' is stored in the Registry and Devart DLLs
are pushed into the Global Assembly Cache.
If EntityDeveloper for EntityDAC wants to register new data prividers in runtime, it must declare other 'InvariantNames', but it does not.

In order to avoid the crash, change the DataProvider names in EntityDeveloper.exe.Config. New names only require to be unique.

In section <DbProviderFactories>
replace

<add name="dotConnect for Oracle" invariant="Devart.Data.Oracle"
description="Devart dotConnect for Oracle" type="Devart.Data.Oracle.OracleProviderFactory, Devart.Data.Oracle, Version=8.1.55.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />

by

<add name="dotConnect for Oracle" invariant="Devart.Data.Oracle1"
description="Devart dotConnect for Oracle" type="Devart.Data.Oracle.OracleProviderFactory, Devart.Data.Oracle, Version=8.1.55.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />

and in section <entityDeveloper>
replace

<add name="Devart.Data.Oracle" type="EntityDeveloper.OracleVendor, EntityDeveloper" />

by
<add name="Devart.Data.Oracle1" type="EntityDeveloper.OracleVendor, EntityDeveloper" />


Of course, if you have other other Devart dotConnect products, ("dotConnect for DB2", "dotConnect for MySQL", "dotConnect for PostgreSQL", "dotConnect for SQLite"), you must perform the same operation.
gwihen
 
Posts: 4
Joined: Tue 07 Aug 2012 15:50

Re: Advice to "dotConnect for XXX" users

Postby ZEuS » Fri 15 Aug 2014 08:45

Thank you for the information. We have reproduced the error. The fix will be included in the next EntityDAC build.
ZEuS
Devart Team
 
Posts: 235
Joined: Thu 05 Apr 2012 07:32


Return to EntityDAC