VS2017 not available with 3.6.435

VS2017 not available with 3.6.435

Postby mst » Thu 29 Jun 2017 05:49

I've updated our Review Assistant installation from 3.6.430 to 3.6.435. On the server everything seems OK, but on the client, Visual Studio 2017 was not available for the integration during the installation.
I continued with just VS 2015 selected. There it works fine.
But when starting VS 2017 I just get an error that the package "Devart.ReviewAssistant.ReviewAssistantPackage, ... Version 3.6.430.0 (!) ... did not load correctly".

So I wanted to revert to 3.6.430. But this setup is now also not showing VS2017 during the setup.
And even after the installation, the error is still showing in VS2017.

Do you have any help regarding this?

VS2017 is Enterprise Edition version 15.2 (26430.14) Release.
VS2015 is Enterprise Edition version 14.0.25431.01 Update 3.
mst
 
Posts: 12
Joined: Tue 03 Sep 2013 08:43

Re: VS2017 not available with 3.6.435

Postby SvetlanaL » Fri 30 Jun 2017 07:16

Hi,

Thank you for reporting the error. It is the known problem. The workaround is:

1 Download 'Clear MEF Component Cache' extension https://marketplace.visualstudio.com/items?itemName=MadsKristensen.ClearMEFComponentCache
2 Select Clear 'MEF Component Cache' in the Visual Studio Tools menu
SvetlanaL
 
Posts: 30
Joined: Mon 06 Feb 2017 09:00

Re: VS2017 not available with 3.6.435

Postby mst » Fri 30 Jun 2017 12:17

I did as you suggested and even uninstalled Review Assistant.
But it still gave this error here (ActivityLog.xml) when starting VS2017:
---
<entry>
<record>289</record>
<time>2017/06/30 12:07:54.011</time>
<type>Error</type>
<source>VisualStudio</source>
<description>CreateInstance failed for package [Devart.ReviewAssistant.ReviewAssistantPackage, Devart.ReviewAssistant.Vs, Version=3.6.430.0, Culture=neutral, PublicKeyToken=09af7300eec23701]Source: &apos;mscorlib&apos; Description: Could not load file or assembly &apos;file:///C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\Devart\Review Assistant\Devart.ReviewAssistant.Vs.dll&apos; or one of its dependencies. The system cannot find the file specified.&#x000D;&#x000A;System.IO.FileNotFoundException: Could not load file or assembly &apos;file:///C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\Devart\Review Assistant\Devart.ReviewAssistant.Vs.dll&apos; or one of its dependencies. The system cannot find the file specified.&#x000D;&#x000A;File name: &apos;file:///C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\Devart\Review Assistant\Devart.ReviewAssistant.Vs.dll&apos;&#x000D;&#x000A; at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark&amp; stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)&#x000D;&#x000A; at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark&amp; stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)&#x000D;&#x000A; at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark&amp; stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)&#x000D;&#x000A; at System.Reflection.RuntimeAssembly.InternalLoadFrom(String assemblyFile, Evidence securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm, Boolean forIntrospection, Boolean suppressSecurityChecks, StackCrawlMark&amp; stackMark)&#x000D;&#x000A; at System.Reflection.Assembly.LoadFrom(String assemblyFile, Evidence securityEvidence)&#x000D;&#x000A; at System.Activator.CreateInstanceFromInternal(String assemblyFile, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo)&#x000D;&#x000A; at System.AppDomain.CreateInstanceFrom(String assemblyFile, String typeName)&#x000D;&#x000A;&#x000D;&#x000A;WRN: Assembly binding logging is turned OFF.&#x000D;&#x000A;To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.&#x000D;&#x000A;Note: There is some performance penalty associated with assembly bind failure logging.&#x000D;&#x000A;To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].&#x000D;&#x000A;</description>
<guid>{2612F0CC-A116-412B-BCB5-73A27D9ECB59}</guid>
<hr>80004005 - E_FAIL</hr>
<errorinfo></errorinfo>
</entry>
<entry>
<record>290</record>
<time>2017/06/30 12:07:54.013</time>
<type>Warning</type>
<source>VisualStudio</source>
<description>Package failed to load; error message suppressed by skip flag</description>
<guid>{2612F0CC-A116-412B-BCB5-73A27D9ECB59}</guid>
</entry>
<entry>
<record>291</record>
<time>2017/06/30 12:07:54.017</time>
<type>Error</type>
<source>VisualStudio</source>
<description>Construction of frame content failed.&#x000D;&#x000A;Frame identifier: ST:0:0:{5c0a8096-0216-4116-858a-17792a4fdd91}&#x000D;&#x000A;Frame caption: Code Review Board&#x000D;&#x000A;Exception details:&#x000D;&#x000A;System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.&#x000D;&#x000A; at Microsoft.VisualStudio.Shell.Interop.IVsShell5.LoadPackageWithContext(Guid&amp; packageGuid, Int32 reason, Guid&amp; context)&#x000D;&#x000A; at Microsoft.VisualStudio.Platform.WindowManagement.WindowFrame.GetPackage()&#x000D;&#x000A; at Microsoft.VisualStudio.Platform.WindowManagement.WindowFrame.ConstructContent()</description>
</entry>
---

So I copied the folder C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\Devart from another PC and now it works fine again in VS2017, even though it is not installed by the setup.

When I start the setup for 3.6.435, I still only see the options to integrate with VS 2010 (shell from SSMS) or VS 2015.

=> How do I properly install version 3.6.435 in VS 2017?
mst
 
Posts: 12
Joined: Tue 03 Sep 2013 08:43

Re: VS2017 not available with 3.6.435

Postby odrozd » Wed 05 Jul 2017 10:45

I can confirm same issue from side. I am using Visual Studio 2017 15.2 26430.14

After upgrading to latest version 3.6.435 of Review Assistant I I had exception described in OP, I cleared MEF component cache and try to reinstall RA, but installer can no longer see Visual Studio 2017 in installation dialog(Visual Studio 2015 available though). I even tried to use previous installer version 3.6.430 but VS 2017 not available there too.

So I am unable to use RA at all with Visual Studio 2017, any tips or workaround's how to fix it?
odrozd
 
Posts: 3
Joined: Tue 21 Feb 2017 10:02

Re: VS2017 not available with 3.6.435

Postby SvetlanaL » Mon 10 Jul 2017 13:29

Hi,

We tried to reproduce this problem with Visual Studio 2017 15.2 (26430.15) Release, but everything works correctly. Please update Visual Studio 2017 to the latest build and if you still have this problem:
1 Check whether a file is blocked by the third-party application, for example, by the antivirus application. Please ensure that the file was not put into the antivirus quarantine.
2 Run GetVsInstances.exe http://devart.com/pub/GetVsInstances.zip and send the vs_instances.txt file to us. This information will help us to solve the problem.
SvetlanaL
 
Posts: 30
Joined: Mon 06 Feb 2017 09:00

Re: VS2017 not available with 3.6.435

Postby odrozd » Tue 11 Jul 2017 12:37

SvetlanaL wrote:Hi,

We tried to reproduce this problem with Visual Studio 2017 15.2 (26430.15) Release, but everything works correctly. Please update Visual Studio 2017 to the latest build and if you still have this problem:
1 Check whether a file is blocked by the third-party application, for example, by the antivirus application. Please ensure that the file was not put into the antivirus quarantine.
2 Run GetVsInstances.exe http://devart.com/pub/GetVsInstances.zip and send the vs_instances.txt file to us. This information will help us to solve the problem.


I have latest VS2017 with all updates installed, also I tried perform "Repair" for VS2017 but without luck.

1) ReviewAssistant installer is not blocked or put on quarantine by anti-virus software.
2) Here is result of GetVsInstances:
10.0
Visual Studio 2010
c:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\
14.0
Visual Studio 2015
C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\
odrozd
 
Posts: 3
Joined: Tue 21 Feb 2017 10:02

Re: VS2017 not available with 3.6.435

Postby SvetlanaL » Thu 13 Jul 2017 11:46

Thank you for your help. The problem will be fixed in the nearest build.
SvetlanaL
 
Posts: 30
Joined: Mon 06 Feb 2017 09:00

Re: VS2017 not available with 3.6.435

Postby mst » Mon 17 Jul 2017 06:26

I tried version 3.6.436 but VS 2017 is still not available in the list during the installation.
Was the correction already included there or will it be in a later version?
mst
 
Posts: 12
Joined: Tue 03 Sep 2013 08:43

Re: VS2017 not available with 3.6.435

Postby mst » Mon 17 Jul 2017 09:07

I've updated VS2017 to 15.2 (26430.15) and this also didn't help. When running the Review Assistant setup, I still only see the options for VS2010 and VS2015, but no VS2017 :-(

Any help would be greatly appreciated.
mst
 
Posts: 12
Joined: Tue 03 Sep 2013 08:43

Re: VS2017 not available with 3.6.435

Postby mst » Mon 17 Jul 2017 14:08

Here's my vs_instances.txt:

10.0
Visual Studio 2010
C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\
14.0
Visual Studio 2015
C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\
15.2
Visual Studio Enterprise 2017
C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE
at Devart.Common.VsInstance.GetAllInstances(Boolean includeNulls)
System.InvalidOperationException
aaaccc
mst
 
Posts: 12
Joined: Tue 03 Sep 2013 08:43

Re: VS2017 not available with 3.6.435

Postby mstislavs » Tue 18 Jul 2017 15:51

mst wrote:Here's my vs_instances.txt:

10.0
Visual Studio 2010
C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\
14.0
Visual Studio 2015
C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\
15.2
Visual Studio Enterprise 2017
C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE
at Devart.Common.VsInstance.GetAllInstances(Boolean includeNulls)
System.InvalidOperationException
aaaccc


Hi, mst!

Try to install the developer build http://devart.com/pub/reviewassistant.exe

Best regards,
Mstislav Sakidon
Devart Team
www.devart.com
mstislavs
 
Posts: 39
Joined: Mon 16 Jan 2017 12:48

Re: VS2017 not available with 3.6.435

Postby mst » Wed 19 Jul 2017 05:49

Thank you Mstislav and Svetlana. This developer build is working fine now.
mst
 
Posts: 12
Joined: Tue 03 Sep 2013 08:43

Re: VS2017 not available with 3.6.435

Postby mst » Mon 24 Jul 2017 06:10

Are you going to release a new version with this correction soon?
mst
 
Posts: 12
Joined: Tue 03 Sep 2013 08:43

Re: VS2017 not available with 3.6.435

Postby gregpakes » Wed 26 Jul 2017 08:13

I have the same issue.
gregpakes
 
Posts: 5
Joined: Tue 02 Feb 2016 01:26

Re: VS2017 not available with 3.6.435

Postby SvetlanaL » Wed 26 Jul 2017 13:23

Since only few users reported this problem, please install developer build to solve it:
http://devart.com/pub/reviewassistant.exe.
If the number of such cases increases, we will release this fix.
SvetlanaL
 
Posts: 30
Joined: Mon 06 Feb 2017 09:00

Next

Return to Review Assistant