Installing Trial w/ SQL Server, Service not starting

Installing Trial w/ SQL Server, Service not starting

Postby barries » Mon 09 Jan 2017 18:18

How can I install the trial version and use it with SQL Server? I can't find the relevant docs, unfortunately, so I've tried to do the obvious things.

Here's what's happening now: the Devart Review Assistant Service starts, then stops quickly, with a "Service cannot be started. The handle is invalid" error in the Windows Application Event Log.

So far, I've installed SQL Server 2016 Express, added an empty database "ReviewAssistant", and used the ReviewAssistantServerConfig.exe to set the connection string to the following and verified it using "Test Connection".

Then I used the Services Control Panel to "Start" Devart Review Assistant. It thought, then gave me the error that the service started and then stopped itself. So I checked the Windows Application Event Log and got the below error.

Code: Select all
Server = localhost\SQLEXPRESS; Database = ReviewAssistant; Integrated Security = False; Trusted_Connection=True;


Code: Select all
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="DevartReviewAssistant" />
  <EventID Qualifiers="0">0</EventID>
  <Level>2</Level>
  <Task>0</Task>
  <Keywords>0x80000000000000</Keywords>
  <TimeCreated SystemTime="2017-01-09T17:23:37.399538300Z" />
  <EventRecordID>16706</EventRecordID>
  <Channel>Application</Channel>
  <Computer>...name elided for this posting...</Computer>
  <Security />
  </System>
- <EventData>
  <Data>Service cannot be started. The handle is invalid</Data>
  </EventData>
  </Event>
barries
 
Posts: 2
Joined: Mon 09 Jan 2017 15:18

Re: Installing Trial w/ SQL Server, Service not starting

Postby barries » Mon 09 Jan 2017 21:05

I now have Review Assistant connecting. It turns out that the Review Assistant Service needed to log into Windows with the same Administrator ID that was used to create the Review Assistant database in SQL Server.

Are there specific directions for how to not need an Administrator account for this?
barries
 
Posts: 2
Joined: Mon 09 Jan 2017 15:18

Re: Installing Trial w/ SQL Server, Service not starting

Postby SvetlanaL » Tue 14 Feb 2017 10:12

Hi,

You use Windows authentication in your connection string. You should start Review Assistant Server under a user with enough permissions to the database. Open Review Assistant Service Properties and change User Account and Password. You will need to do it every time after reinstallation of Review Assistant Server.
The other way is a usage of Trusted_Connection=Fasle with a user and password in the connection string.

For example:
Code: Select all
Server = localhost\SQLEXPRESS; Database = ReviewAssistant; Integrated Security = False; User = user; Password = password;
SvetlanaL
 
Posts: 30
Joined: Mon 06 Feb 2017 09:00


Return to Review Assistant