Unable to read data from the transport connection

Unable to read data from the transport connection

Postby giuliano » Mon 18 Oct 2010 13:12

Hello,
I have a large SQL query that takes on average one and a half minutes to complete.

At exactly 30 seconds of the query, I get an error stating the following:
"Unable to read data from the transport connection"

"I am using version 3.20.16.00 of the Devart dotConnect Professinal Universal." with the platform. NET Framework 4.0 and I configured the CommandTimeout property to zero before executing the query.

Can anyone help me?
giuliano
 
Posts: 24
Joined: Mon 18 Oct 2010 12:59

Postby Shalex » Wed 20 Oct 2010 17:43

I have reproduced the UniCommand.CommandTimeout problem when connecting to Oracle Server in Direct Mode. We will investigate the problem and notify you about the results as soon as possible.

Please specify the database server you are working with and your connection string parameters.

We have removed your post from http://www.devart.com/forums/viewtopic.php?t=1269 as duplicated.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby giuliano » Thu 21 Oct 2010 11:57

I am using the PostgreSQL database 8.3.3 on i386-portbld-freebsd7.0, compiled by GCC cc (GCC) 4.2.1 20070719 [FreeBSD]
giuliano
 
Posts: 24
Joined: Mon 18 Oct 2010 12:59

Postby Shalex » Thu 21 Oct 2010 13:21

We have fixed bug with UniCommand.CommandTimeout. I will post here when the corresponding build is available for download.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby Shalex » Thu 04 Nov 2010 14:31

New build of dotConnect Universal 3.20.27 is available for download now!
It can be downloaded from http://www.devart.com/dotconnect/univer ... nload.html (trial version) or from Registered Users' Area (for users with valid subscription only).
For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=19426 .
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect Universal