3.01 Not Working With Delphi XE3 - DbxDevartSQLiteDriver170.bpl Missing

3.01 Not Working With Delphi XE3 - DbxDevartSQLiteDriver170.bpl Missing

Postby DespatchSystems » Fri 14 Sep 2012 14:04

Hi,

I downloaded and installed v3.01 (registered user, not trial) with Delphi XE3 trial edition.

When I start the Delphi XE3 IDE, I get the error message "Cannot load package C:\Program Files (x86)\Embarcadero\RADStudio\10.0\Bin\DbxDevartSQLiteDriver170.bpl".

I have checked the folder and the DbxDevartSQLiteDriver170.bpl is not in the folder.

The install completed without any errors.

Is there a problem with the 3.01 installer or I have I missed something as part of the installation??

Good news on the encryption support, I have been waiting for this!!

Hope you can help.

Greg
DespatchSystems
 
Posts: 14
Joined: Tue 24 Jul 2012 10:45

Re: 3.01 Not Working With Delphi XE3 - DbxDevartSQLiteDriver170.bpl Missing

Postby AlexP » Tue 18 Sep 2012 08:47

hello,

When installing our dbExpress driver for SQLite Standard Edition, all necessary files are copied to the right directories. Perhaps, you have no rights for writing to this folder (C:\Program Files (x86)\Embarcadero\RADStudio\10.0\Bin\), you can copy the needed files manually from the C:\Program Files\Devart\Dbx\SQLite\Delphi16\Win32[Win64, OSX32] folder, or grand writing to the folder and reinstall the driver. If you use the edition with source code, you should copy the files manually as well.
AlexP
Devart Team
 
Posts: 5528
Joined: Tue 10 Aug 2010 11:35

Re: 3.01 Not Working With Delphi XE3 - DbxDevartSQLiteDriver170.bpl Missing

Postby DespatchSystems » Tue 18 Sep 2012 18:07

Hi,

I ran the installer at administrator to make sure I have permission. The bpl is still missing when I start Delphi XE3. I am running Windows 7 x64 with Delphi XE3 trial.

I don't have the version of your software with source code, the folder C:\Program Files (x86)\Devart\Dbx\SQLite\Bin\Win32\ does not contain the necessary bpl file to copy over manually either? It only contains the files:

dbexpsqlite.dll
dbexpsqlite30.dll
dbexpsqlite40.dll

Have you tested the installer without source code with Delphi XE3?

Can you give me access to the installer that includes source code to see if it fixes the issue?

Thanks for your help.

Greg
DespatchSystems
 
Posts: 14
Joined: Tue 24 Jul 2012 10:45

Re: 3.01 Not Working With Delphi XE3 - DbxDevartSQLiteDriver170.bpl Missing

Postby jolli » Tue 18 Sep 2012 20:32

Hi,

i have the same issue using the Delphi XE3 Trial and the dbExpress Oracle driver version 6.0.1.
For me the file DbxDevartOracleDriver170.bpl is missing in the folder "C:\Program Files (x86)\Embarcadero\RAD Studio\10.0\bin". Even re-installing the devart driver with User Write rights set on the folder didn't fix it.
Can someone provide help with this issue?
Best regards,

Jolli
jolli
 
Posts: 2
Joined: Tue 18 Sep 2012 20:24

Re: 3.01 Not Working With Delphi XE3 - DbxDevartSQLiteDriver170.bpl Missing

Postby AlexP » Wed 19 Sep 2012 14:27

hello,

We've already fixed the problem and uploaded the installation file, please download it once more.
AlexP
Devart Team
 
Posts: 5528
Joined: Tue 10 Aug 2010 11:35

Re: 3.01 Not Working With Delphi XE3 - DbxDevartSQLiteDriver170.bpl Missing

Postby jolli » Wed 19 Sep 2012 14:41

Hi Alex,

thanks for the quick reply.
Now everything works for me.
I hope it does for Greg, too :-)
jolli
 
Posts: 2
Joined: Tue 18 Sep 2012 20:24

Re: 3.01 Not Working With Delphi XE3 - DbxDevartSQLiteDriver170.bpl Missing

Postby DespatchSystems » Thu 20 Sep 2012 13:14

Fixed for me to in the new updated build of 3.01.
DespatchSystems
 
Posts: 14
Joined: Tue 24 Jul 2012 10:45


Return to dbExpress driver for SQLite