Could not parse the GetTables metadata command

Could not parse the GetTables metadata command

Postby joedbat » Wed 30 Jul 2014 13:57

Hi,
I'm trying to use the 3.4.6 version of the driver. I was using the 2.1.3 version and it was working just fine. Now, i want to move to XE6 from XE2 and i've purchased the new version.
With XE6 i made a new project, put an TSQLConnection component, fill the parameters and try to activate the connection. It worked. Then i put an TSQLDataSet component, fill the command text with a basic query (select * from sisempresa) and did not work. Then, i try to change the command type to ctTable and get the following error: "Could not parse the GetTables metadata command. Problem found near: 186.202.166.79. Original query: GetTables 186.202.166.79/intelitime . intelitime .% Table;View;.."
This is my enviroment:
Windows 8.1
Delphi XE6
Database: PostgreSQL 9.2.4

Connection Parameters:
DriverName=DevartPostgreSQL
DataBase=186.202.166.79/intelitime
User_Name=intelitime
Password=XXXXXX
FetchAll=True
EnableBCD=True
UseUnicode=False

Thank you for your suport.

Best Regards,
Joemerson de Oliveira
Intelitime Soluções
joedbat
 
Posts: 2
Joined: Tue 19 Jan 2010 18:45

Re: Could not parse the GetTables metadata command

Postby ViktorV » Thu 31 Jul 2014 13:04

To avoid this issue, you should be corrected connection settings in the TSQLConnection component.

Connection Parameters:
DriverName=DevartPostgreSQL
DataBase=intelitime
HostName=186.202.166.79
User_Name=intelitime
Password=XXXXXX
FetchAll=True
EnableBCD=True
UseUnicode=False
ViktorV
Devart Team
 
Posts: 1869
Joined: Wed 30 Jul 2014 07:16


Return to dbExpress driver for PostgreSQL