PostgreSQL log messages

PostgreSQL log messages

Postby Reginaldo » Wed 10 Jun 2009 18:09

Everytime I try to connect to PG (Windows install) via Delphi, PostgreSQL log files (at C:\Program Files\PostgreSQL\8.3\data\pg_log) show these messages on connecting (after a TSQLConnection.Active := True;):

2009-06-09 13:13:11 BRT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2009-06-09 13:13:11 BRT LOG: invalid password packet size

and this message on disconnecting (after a TSQLConnection.Active := False;)

2009-06-09 13:15:00 BRT LOG: unexpected EOF on client connection

I just place a TSQLConnection on a TForm, and set up Params property as:
HostName=127.0.0.1
Database=test
User_Name=testuser
Password=test
UseUnicode=False

Should I worry about these messages? Are they errors caused by my application?

Thanks in advance.
Reginaldo
 
Posts: 7
Joined: Sat 09 May 2009 21:46

Postby Plash » Mon 15 Jun 2009 07:15

We have fixed these problems. The fix will be included in the next build of the driver.
Plash
Devart Team
 
Posts: 2844
Joined: Wed 10 May 2006 07:09

Re: PostgreSQL log messages

Postby tonylabb » Tue 13 Aug 2013 19:39

I just upgraded to UniDAC 5.02 from a version 4.xx. We're running PostgresSQL version 9.0. I am now getting the "invalid password packet size" message in my logs when I never did before. This happens simply by doing a TUniConnection.Open.
tonylabb
 
Posts: 3
Joined: Tue 13 Aug 2013 19:25

Re: PostgreSQL log messages

Postby DemetrionQ » Wed 14 Aug 2013 11:29

Hello.

I answered to you at the topic http://forums.devart.com/viewtopic.php?t=27742
DemetrionQ
Devart Team
 
Posts: 271
Joined: Wed 23 Jan 2013 11:21


Return to dbExpress driver for PostgreSQL