Devart LinqConnect Model missing, windows 7, VS 2010

Devart LinqConnect Model missing, windows 7, VS 2010

Postby Sulphy » Wed 12 Sep 2012 18:18

Hi,

At work we use Windows 7 and Visual Studio 2010. A fresh install of Devart LinqConnect.

My previous experience (which is limited) with this tool is that I can create a new project e.g. an MVC web application. After creating the project I then opt to add a new item from the solution explorer and from the wizard I click on the 'Data' node to filter/reduce the list of templates available. Historically I would see the Devart LinqConnect Model template listed. And this is what is shown in the help files.

However for this fresh installation the template is missing. I've seen some posts where it says you should opt for Visual Studio integration during installation. However this isn't an option that available during install as far as I can see.

I have come home and and done a fresh install of both VS 2008 and 2010 then put on the latest version that came out on 6th September in the hope this would work. However it doesn't. I'm expecting to be able to model an Oracle database using the Devart LinqConnect Model template etc. I've tried looking at the help files and searching on google, alas no luck.

Any ideas?

Thanks.
Sulphy
 
Posts: 34
Joined: Wed 12 Sep 2012 18:07

Re: Devart LinqConnect Model missing, windows 7, VS 2010

Postby MariiaI » Thu 13 Sep 2012 12:45

Please specify what edition of LinqConnect exactly you are installing. In particular, please make sure you are not installing LinqConnect for Metro, which is not intended to be used with Visual Studio 2008 or 2010.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Devart LinqConnect Model missing, windows 7, VS 2010

Postby Sulphy » Tue 25 Sep 2012 09:46

Hi,

thanks for coming back to me. I've uninstalled and reinstalled (as a double check) and used LinqConnect 4.1.82 trial edition (therefore not the metro edition). I can run the Entity Framework program independently and manually add references to the DLLs so I can code stuff manually. However the option to launch the Entity Framework model wizard via the IDE just isn't showing up as indicated in the help files and what I've seen historically on other systems. All defaults during installation (which are all checked) are left intact.
Sulphy
 
Posts: 34
Joined: Wed 12 Sep 2012 18:07

Re: Devart LinqConnect Model missing, windows 7, VS 2010

Postby MariiaI » Tue 25 Sep 2012 12:20

Please specify the kind of the model you want to create - Devart LinqConnect Model or Devart Entity Model? In the latter case - the Entity Framework model can not be created using LinqConnect.
LinqConnect provides the ORM solution plus basic connectivity functionality for each supported DBMS. Our data providers (e.g. dotConnect for Oracle), on other hand, include support for both the LinqConnect ORM and Entity Framework. Thus, to be able to create Entity Framework models, you should work with dotConnect for Oracle.

For more information, please refer to:
http://www.devart.com/dotconnect/oracle/editions.html
http://www.devart.com/dotconnect/entityframework.html
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Devart LinqConnect Model missing, windows 7, VS 2010

Postby Sulphy » Mon 29 Oct 2012 13:30

Hi again,

Just to post an update and solution to my original question. For clarity I work in a large financial institution and software has to be 'packaged' up for general deployment to the user base. Being so new to both Visual Studio and Devart LinqConnect probably didn't help matters. Basically the test machine our packaging team use didn't have Visual Studio 2010 Professional already loaded. When the installer was kicked off it made no reference or option for the 'integration for visual studio 2010'.

I got hold of a trial edition of Visual Studio 2010 and tried the installer and straight away could see the option in the installation wizard. So I've now got it to install perfectly on my machine at home. I had been using the free web developers edition of Visual Studio 2010 at home also, which I hadn't realized was being treated by the installer in the same way e.g. hide the integration option.

So obvious now when you think about it :o)

Thanks,
Sulphy
 
Posts: 34
Joined: Wed 12 Sep 2012 18:07

Re: Devart LinqConnect Model missing, windows 7, VS 2010

Postby MariiaI » Mon 29 Oct 2012 15:59

The option for the integration into Visual Studio is not available when one of the Visual Studio Express editions is used.
In this case, the problem is that it does not support third-party add-ins, so LinqConnect can't be integrated into it. However, Entity Developer, installed with LinqConnect, can also be used as a standalone application regardless of the Visual Studio edition.
For more information about Entity Developer, please refer to:
http://www.devart.com/entitydeveloper/
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17


Return to LinqConnect (LINQ to SQL support)