sspi

Postby cjbiggs » Fri 26 Aug 2011 16:05

Any update on the GSSAPI implementation? Can you send me a sample test application in case I am doing something wrong in my application?

Thanks,

Charlie J.
cjbiggs
 
Posts: 105
Joined: Fri 15 Jan 2010 19:56

Postby Shalex » Tue 30 Aug 2011 06:07

Could you please try Npgsql Provider in the same environment? Does it work?
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby cjbiggs » Tue 30 Aug 2011 13:47

As I have mention certain times before, It works well with NpgSQL. We had to switch to NpgSQL because Devart did not support GSSAPI. It is not an issue with our environment. The issue is your dotConnect for Postgres does not support GSSAPI. The NpgSQL driver is Open Source, so you should be able to get an idea of how to implemented from reviewing what they did.

Thanks,

Charlie J.
cjbiggs
 
Posts: 105
Joined: Fri 15 Jan 2010 19:56

Postby Shalex » Thu 01 Sep 2011 10:31

We have compared our implementation of GSS with the one of NpgSQL. They are identical. The issue should be in your environment. Refer to http://postgresql.1045698.n5.nabble.com/GSS-Authentication-td1919096.html.

We have also implemented some minor changes in our implementation of GSS. Look forward to the next build of dotConnect for PostgreSQL.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby cjbiggs » Thu 01 Sep 2011 13:40

Sorry. The issue is not in our environment. Npqsql works in our environment after my company submitted a patch to fix Npgsql. So if you are using there open source code for your implementation of GSSAPI, please make sure you get the code fix submitted by my company SSCS (Mike Kock) from there web site. I am sure the small changes that you said you implemented and will be in the next build will fix my problem I hope.

Please read the post to the PgFoundry about the fix to the Npgsql driver to get it to truly work with GSSAPI.

http://pgfoundry.org/forum/message.php?msg_id=1014589

Thanks,

Charlie J.
cjbiggs
 
Posts: 105
Joined: Fri 15 Jan 2010 19:56

Postby Shalex » Fri 02 Sep 2011 08:58

Charlie,
Thank you. We have implemented the corresponding patch in dotConnect for PostgreSQL. We will post here when the next build of dotConnect for PostgreSQL is available for download.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby cjbiggs » Fri 02 Sep 2011 13:44

Thanks. Very happy to help to get this implemented. We will test it in our environment as soon as it is available.

Thanks,

Charlie J. Biggs
cjbiggs
 
Posts: 105
Joined: Fri 15 Jan 2010 19:56

Postby cjbiggs » Tue 06 Sep 2011 22:38

Was this issue resolved in the release from yesterady? PostgreSQL 5.50


Thanks,

Charlie J.
cjbiggs
 
Posts: 105
Joined: Fri 15 Jan 2010 19:56

Postby Shalex » Wed 07 Sep 2011 11:59

New version of dotConnect for PostgreSQL 5.50 is released!
It can be downloaded from http://www.devart.com/dotconnect/postgr ... nload.html (trial version) or from Registered Users' Area (for users with valid subscription only): http://secure.devart.com/ .
For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=21944 .

This version includes the mentioned fix.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby cjbiggs » Wed 07 Sep 2011 13:19

I have downloaded dotConnect for PostgreSQL 5.50. The GSS implemention is still not working. I get a different error message this time. A token was invalid: unknown mech-code 0 for mech unknown"

The NpgSQL still works in my environment. Is there a test application or assembly logging you can provide to help trace into this issue? Is there anything I can turn on that would help pin-point the issue.

Have you tested it against the same environment that I mention I was using in this forum?

Thanks,

Charlie J.
cjbiggs
 
Posts: 105
Joined: Fri 15 Jan 2010 19:56

Postby Shalex » Thu 08 Sep 2011 10:48

We have sent the new test assemblies to you by e-mail. Please try them and notify us about the results.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby cjbiggs » Thu 08 Sep 2011 13:27

Hi,

I did not receive an email with the new test assemblies. Please email it to cjbiggs@theinnovationbox.com


Thanks,

Charlie J.
cjbiggs
 
Posts: 105
Joined: Fri 15 Jan 2010 19:56

Postby Shalex » Thu 08 Sep 2011 13:39

Done.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby cjbiggs » Thu 08 Sep 2011 20:38

Thanks. The test assemblies you send me did allow us to log in. But we get this error message after we log in

Schema specified is not valid. Errors:
DevPriceBook.ssdl(2,105) : error 0004: Could not load file or assembly 'Devart.Data.PostgreSql.Entity, Version=5.30.210.0, Culture=neutral, PublicKeyToken=09af7300eec23701' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Can you send your a complete package build with this fix in it? We are currently using the latest dotConnect for Postgres 5.50

Please email it to cjbiggs@theinnovationbox.com

Thanks,

Charlie J.
cjbiggs
 
Posts: 105
Joined: Fri 15 Jan 2010 19:56

Postby Shalex » Fri 09 Sep 2011 10:25

Charlie,
Thank you for your assistance that helped us to fix the problem in our GSS implementation.
According to our policy, we may send an internal build of dotConnect for PostgreSQL to you after validating your subscription status. Please e-mail to me (alexsh at devart*com) the following information you have used when registering our product:
1) e-mail;
2) personal name;
3) company name;
4) if possible, the order number.
Looking forward to your e-mail.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

PreviousNext

Return to dotConnect for PostgreSQL