Unexpected Error in Visual Studio 2005

Unexpected Error in Visual Studio 2005

Postby william235 » Wed 04 Oct 2006 12:42

Iam having difficulty after installing this product
in Visual Studio 2005. Although installation appears to have been
sucessful, when I attempt to add a database connection I get:

"an unexpected error has occurred in the Postgresql .net data provider.
please contact vendor to resolve this problem."

There is no other information, just that error. I am a registered user using psqlnet 2.5 2
william235
 
Posts: 4
Joined: Wed 04 Oct 2006 12:39

Postby Alexey » Wed 04 Oct 2006 13:04

What edition of Visual Studio do you use?
Specify your hardware architecture: x32 or x64?
What version of PostgreSQLDirect .NET do you use (Std, Pro, Mobile)?
What is the full version of the dll (2.XX.XX.X)?
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Reply to request for more information

Postby william235 » Thu 05 Oct 2006 21:53

Thanks for your reply to my inquiry. Following are the answers to your questions:

Windows XP SP2
Visual Studio 2005 Specifically Visual Basic
X32 Architecture
PostgreSQLDirect .NET Pro
The full version of the dll is (2.50.15.0)

The error occurs immediately when I right click on data connections in order to open a new connection.

Thanks again for your help.
william235
 
Posts: 4
Joined: Wed 04 Oct 2006 12:39

Postby Alexey » Fri 06 Oct 2006 06:28

Version 2.50.15.0 is not the last one. Please download the latest PostgreSQLDirect .NET from our site and use it.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Problem is still there

Postby william235 » Tue 10 Oct 2006 01:32

I have downloaded the most recent version of the dll 2.50.21.0. Still get exactly the same error message.
william235
 
Posts: 4
Joined: Wed 04 Oct 2006 12:39

Postby Alexey » Tue 10 Oct 2006 06:42

The error occurs immediately when I right click on data connections in order to open a new connection.
What data connections do you mean?
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Previous Question

Postby william235 » Tue 10 Oct 2006 12:47

Thanks again for your assistance.

When I right click on "Data Connections" in the database explorer pane and choose add connection the problem occurs.

If I go in the tools menu and use the dataset wizard I can get a lot further, seeing the tables and all of that, but the connection is never made. The problem occurs when I attempt a new connection to the db. I have verified using PGAdmin that I am connected and the database is online.

I have tried this on another separate machine on the same network that has VS2005 and get the same error. Also, to clarify, I am using VS2005 Standard edition primarily with visual basic.
william235
 
Posts: 4
Joined: Wed 04 Oct 2006 12:39

Postby Alexey » Tue 10 Oct 2006 13:54

Try to run "devenv /resetskippkgs" from the command line.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for PostgreSQL