Problems in Visual Studio 2005

Problems in Visual Studio 2005

Postby richard » Tue 05 Sep 2006 15:31

I have installed the trial version (build 19) and am not able to use the product at all with VS 2005.

- Server explorer doesn't work
- Dataset wizard doesn't always work (sometimes get an Index out of bounds exception)
- when Dataset wizard does work (on some tables), I have never been able to use the resulting dataset. For example, it will crash Visual Studio trying to bind to a DataGridView.
- also interferes with the use of other data providers, since it stops the use of the Add New Data Source with an exception, even if I don't want to use PGSQL (error occurs when clicking "New Connection")

Richard
richard
 
Posts: 11
Joined: Tue 05 Sep 2006 14:53
Location: Full

More about

Postby Ritvar » Wed 06 Sep 2006 10:07

Also I want to report strange Dataset wizard behaviour with some tables,
it fails with MessageBox string nessage "Column 'Tables' does not belong to table 'ForeignKeys'".
Table SQL here and version 2.50.17.0
Code: Select all
CREATE TABLE emp
(
  empno int4 NOT NULL,
  ename varchar(10),
  job varchar(9),
  mgr int4,
  hiredate date,
  sal float4,
  comm float4,
  deptno int4,
  CONSTRAINT emp_pkey PRIMARY KEY (empno),
  CONSTRAINT emp_deptno_fkey FOREIGN KEY (deptno)
      REFERENCES dept (deptno) MATCH SIMPLE
      ON UPDATE NO ACTION ON DELETE NO ACTION
)
WITHOUT OIDS;
ALTER TABLE emp OWNER TO postgres;


This issue is not new - I saw old report on Your forum.

Can You fix it? Main reason to buy Your Pg adapters were based on good
expierence with Your MySql adapter. Do I need to write strongly typed DS by hands?
Ritvar
 
Posts: 2
Joined: Sun 11 Dec 2005 14:16

Re: Problems in Visual Studio 2005

Postby Alexey » Wed 06 Sep 2006 10:30

richard wrote:- Dataset wizard doesn't always work (sometimes get an Index out of bounds exception)
Please provide me the table definition which causes error.
Also specify your hardware architecture: x32 or x64?
Ritvar wrote:version 2.50.17.0
Try to install the latest version from our site.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Re: Problems in Visual Studio 2005

Postby richard » Wed 06 Sep 2006 13:16

My machine has an AMD Turion 64 (I reported the first error by email previously, before I noticed the forums).

Table definition (one of many that fails):

Code: Select all
-- Table: wp_phone_events

-- DROP TABLE wp_phone_events;

CREATE TABLE wp_phone_events
(
  pe_id serial NOT NULL,
  longitude float8 NOT NULL,
  latitude float8 NOT NULL,
  gpstime timestamp NOT NULL,
  pet_id int4 NOT NULL,
  geo geometry,
  heading float8,
  CONSTRAINT wp_phone_events_pkey PRIMARY KEY (pe_id),
  CONSTRAINT phone_events_to_phone_events_type FOREIGN KEY (pet_id)
      REFERENCES wp_phone_events_type (pet_id) MATCH SIMPLE
      ON UPDATE CASCADE ON DELETE CASCADE,
  CONSTRAINT enforce_srid_geo CHECK (srid(geo) = 4326)
)
WITHOUT OIDS;
ALTER TABLE wp_phone_events OWNER TO webmaster;


-- Index: fki_phone_events_to_phone_events_type

-- DROP INDEX fki_phone_events_to_phone_events_type;

CREATE INDEX fki_phone_events_to_phone_events_type
  ON wp_phone_events
  USING btree
  (pet_id);

[/code]
richard
 
Posts: 11
Joined: Tue 05 Sep 2006 14:53
Location: Full

Postby Alexey » Thu 07 Sep 2006 06:36

Please check whether you have two machine.config files:
first under [Windows\Microsoft.NET\Framework\v2.#.#####\Config\] and second under [Windows\Microsoft.NET\Framework64\...].
Then check whether appropriate DBProviderFactories entry exists in the first machine.config file. If not copy it from the second one and reboot.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby richard » Thu 07 Sep 2006 13:08

I don't have a Framework64 folder, so there is only one machine.config file.
richard
 
Posts: 11
Joined: Tue 05 Sep 2006 14:53
Location: Full

Postby Alexey » Thu 07 Sep 2006 13:13

Please send to the address provided in the Readme file.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for PostgreSQL