Connection Hangs When Wrong Username/Password Provided

Connection Hangs When Wrong Username/Password Provided

Postby gabrielnasser » Thu 06 Jul 2006 08:59

Hello,

I'm using CoreLab.PostgreSql v 2.50 with VS 2005. I have a C# project and when I try to open a connection synchronously using incorrect username/password then the method hangs indefinitely. The call works properly when the credentials are correct.

Here's my connection string.

"User Id=admin;Password=admin;Host=localhost;Database=tjsdb;Connection Timeout=5;Pooling=False;"

What could be the problem?

Gabriel
gabrielnasser
 
Posts: 15
Joined: Wed 25 Jan 2006 19:57

Postby Alexey » Thu 06 Jul 2006 10:42

What is the version of your PostgreSql server?
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby gabrielnasser » Thu 06 Jul 2006 13:08

8.1.3 Running on Windows XP SP2.
gabrielnasser
 
Posts: 15
Joined: Wed 25 Jan 2006 19:57

Postby Alexey » Thu 06 Jul 2006 13:39

Please describe your configuration (local/remote server?, firewall?).
Could you provide us with a test account on your server, so we may try to connect to it.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby gabrielnasser » Thu 06 Jul 2006 13:41

The testing is done on the local machine - no firewall. I am unable to provide you with access to my machine.
gabrielnasser
 
Posts: 15
Joined: Wed 25 Jan 2006 19:57

Postby Alexey » Tue 11 Jul 2006 08:23

We tested this with PostgreSQL 8.1.4 and could not reproduce such behaviour. We get an error like "password authentication failed for user 'postgres'". We have default settings of PostgreSQL server.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby gabrielnasser » Wed 12 Jul 2006 06:07

But my environment is using 8.1.3? Have you tested with that?
gabrielnasser
 
Posts: 15
Joined: Wed 25 Jan 2006 19:57

Postby Alexey » Wed 12 Jul 2006 12:06

With PostgreSQL 8.1.3 same situation as with 8.1.4. I've just performed the test.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby gabrielnasser » Wed 19 Jul 2006 09:41

I have just exposed the machine temporarily.

Host: 195.229.241.183
Port: 5432

You can use any username/password combination to check that it is hanging.

Please let me know when you are done so that I can shutdown the port.

Thank you.
gabrielnasser
 
Posts: 15
Joined: Wed 25 Jan 2006 19:57

Postby Alexey » Wed 19 Jul 2006 10:44

Is your port still available? We are trying to connect right now with no success unfortunately.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby gabrielnasser » Wed 19 Jul 2006 10:53

Please try hostname: tjs2.no-ip.biz
gabrielnasser
 
Posts: 15
Joined: Wed 25 Jan 2006 19:57

Postby Alexey » Wed 19 Jul 2006 11:50

Getting the error
FATAL: password authentication failed for user "postgres"

It is not hanging.
What is the full version of your PostgreSQLDirect?
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby gabrielnasser » Wed 19 Jul 2006 11:58

PostgreSqlDirect version 2.50.15.0 running in Release version on same local machine. Platform is Windows XP SP2 with .NET 2.0.
gabrielnasser
 
Posts: 15
Joined: Wed 25 Jan 2006 19:57

Postby Alexey » Wed 19 Jul 2006 12:24

Just tested. Same results.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby gabrielnasser » Wed 19 Jul 2006 12:28

We are experience the same problem with this version at 19 deployed sites - not just the test machine.

What do you suggest we do at the moment?
gabrielnasser
 
Posts: 15
Joined: Wed 25 Jan 2006 19:57

Next

Return to dotConnect for PostgreSQL