PGPool-II 3.6

PGPool-II 3.6

Postby thom4fun » Thu 06 Jul 2017 19:24

I am running PGPool II 3.6 on his own machine in front of 2 PostgreSQL servers.
After a lot of struggling with configuration and settings, this configuration works very nice in Master/Slave mode with streaming replication.

As well, I can connect and run SQL query’s, as well nice surrounded with transactions (IsolationLevel.Serializable)
But if I use inside a transaction with IsolationLevel Serializable a Devart.Data.PostgreSql.PgSqlLoader, I run in the problems that the command will never returned (finished) on pgpool.
I found similar error descriptions inside the forum, but all of them for years old. The only difference is, that I have the problem only if I use the loader.

The versions I use:
PGPool 3.6
PostgreSQL 9.4
dcpostgresql76pro

Do you have any hint how to use the loader within this configuration?
I tried to disable pooling on both sides, as well all IsolationLevel and Protokoll 2 and 3, no success

Many thanks in advance
Thomas
thom4fun
 
Posts: 3
Joined: Wed 08 Sep 2010 15:19

Re: PGPool-II 3.6

Postby Pinturiccio » Thu 13 Jul 2017 14:00

We are working on creation of the corresponding test environment with Pgpool-II 3.6. We will post here when we get any results.
Pinturiccio
Devart Team
 
Posts: 2026
Joined: Wed 02 Nov 2011 09:44

Re: PGPool-II 3.6

Postby thom4fun » Sun 10 Sep 2017 20:49

Any news about that?
thom4fun
 
Posts: 3
Joined: Wed 08 Sep 2010 15:19

Re: PGPool-II 3.6

Postby Pinturiccio » Mon 25 Sep 2017 15:24

Sorry for the late response. The investigation is in progress. We will post here when we get any results.
Pinturiccio
Devart Team
 
Posts: 2026
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for PostgreSQL