Error message after re-installing

Error message after re-installing

Postby jrogovsky » Fri 05 May 2017 17:07

I previously had VS2015 Pro and VS2017 Community installed with dotConnect.

A few days ago I uninstalled VS2017 Community and installed VS2017 Pro. I then reinstalled dotConnect to make sure it was integrated with VS2017 Pro.

Now, every time I start VS2015, I get an error related to DevArt: link.

Any suggestions on how to remove the error message?
jrogovsky
 
Posts: 12
Joined: Thu 06 Apr 2017 21:36

Re: Error message after re-installing

Postby Shalex » Mon 08 May 2017 14:01

Please reinstall dotConnect for PostgreSQL with checking environment:
1) uninstall dotConnect for PostgreSQL, Entity Developer, and other Devart ADO.NET products (if any)
2) make sure (via some file manager like https://x-diesel.com/ ) that there are no Devart.* and policy.*.Devart.* files in the following folders:
* GAC 2.0 (\Windows\assembly\GAC_MSIL\)
* GAC 4.0 (\Windows\Microsoft.NET\assembly\GAC_MSIL\)
3) clear the directories:
* \Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\PrivateAssemblies\Devart\
* \Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\PrivateAssemblies\Devart\
* \Program Files (x86)\Devart\
* \Program Files (x86)\Common Files\Devart\
* \Documents and Settings\All Users\Devart\EntityDeveloper\
* \Documents and Settings\All Users\Devart\dotConnect\
4) run installation of dotConnect for PostgreSQL via its right click > Run as administrator menu

Did it help? If not, run "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.com" /ResetSkipPkgs (http://msdn.microsoft.com/en-us/library/ms241276.aspx).

If the problem persists after this, please send us your C:\Users\jrogovsky\AppData\Roaming\Microsoft\VisualStudio\14.0\ActivityLog.xml.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for PostgreSQL