EF Core 1.1 support (dotConnect for PostgreSQL 7.8.862)

EF Core 1.1 support (dotConnect for PostgreSQL 7.8.862)

Postby lukas.kubis » Thu 30 Mar 2017 06:06

Hi,

I’ve recently installed the latest version of dotConnect for PostgreSQL 7.8.862 and I’m having some issues to make my application running.

My application targets framework .NETCoreApp 1.1 and has dependencies on the following libs:
Assemblies:
- Devart.Data (5.0.1654.0)
- Devart.Data.PostgreSQL (7.8.862.0)
- Devart.Data.PostgreSQL.Entity.EFCore (7.8.862.0)
- Devart.Data.PostgreSQL.Entity.EFCore.Design (7.8.862.0)
NuGet:
- Microsoft.EntityFrameworkCore.Tools (1.1.0)

But when I create this class, I can’t compile it:

Code: Select all
public class MyDbContext : DbContext
{
    protected override void OnConfiguring(DbContextOptionsBuilder optionsBuilder)
    {
        // this line causes the build error
        optionsBuilder.UsePostgreSql(“connection string goes here”);
    }
}


Build output:
  • error CS0012: The type 'Action<>' is defined in an assembly that is not referenced. You must add a reference to assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.
  • error CS0012: The type 'DbConnection' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

Am I doing something wrong, or it is not supported yet?

Best Regards
Lukas
lukas.kubis
 
Posts: 1
Joined: Thu 30 Mar 2017 05:58

Re: EF Core 1.1 support (dotConnect for PostgreSQL 7.8.862)

Postby Shalex » Thu 30 Mar 2017 15:02

EF Core is being developed by Microsoft for the following target platforms:
* .NET 4.5.1 and higher -> EF Core for this platform is supported by dotConnect for PostgreSQL
* .NET Core -> in progress
* Universal Windows Platform -> under review

A current workaround for adding the Devart.* assemblies in .NET Core project is described at http://forums.devart.com/viewtopic.php?f=1&t=34352#p119065 to target "dnx451" (instead of "netcoreapp1.0").

We are working on the .NET Core support. It will be implemented soon. We will notify you when the feature is available.
Shalex
Devart Team
 
Posts: 7775
Joined: Thu 14 Aug 2008 12:44

Re: EF Core 1.1 support (dotConnect for PostgreSQL 7.8.862)

Postby Shalex » Tue 30 May 2017 14:21

Devart is glad to announce the release of dotConnect for PostgreSQL 7.9 with support for .NET Core: http://forums.devart.com/viewtopic.php?f=3&t=35438.

If you have any questions, feel free to contact us.
Shalex
Devart Team
 
Posts: 7775
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for PostgreSQL