c# project with dotconnect for postgres not running on other computers!

c# project with dotconnect for postgres not running on other computers!

Postby tco95ttocs » Wed 14 Sep 2016 09:30

I have a c# project (vs2013) with dotconnect for postgresql.
On my computer the project is running fine.
But on other ones it won't start. I copied all necessary dlls to the project-folder, but nothing happens.
I figured out, that it must be something with dotconnect, because when i install dotconnect on the other computers, my program worked fine. After deinstallation it crashs again!
I also added all Devart dlls to the GAC, still not working.
So where is the problem? Is it necessary to install dotconnect on all computers? Or is there another solution?

With best regards
Mario
tco95ttocs
 
Posts: 5
Joined: Wed 20 Apr 2016 06:56

Re: c# project with dotconnect for postgres not running on other computers!

Postby Shalex » Wed 14 Sep 2016 15:56

1. Please refer to https://www.devart.com/dotconnect/postgresql/docs/?deployment.html.
2. Be aware that your application should include the provider-specific license resource. You can add it via Tools > PostgreSQL > License Information. For more information, refer to https://www.devart.com/dotconnect/postgresql/docs/?licensing.html.

If this doesn't help, add the try...catch logic in your code to find out the exact text of the exception and its full stack trace. Please specify this information.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Re: c# project with dotconnect for postgres not running on other computers!

Postby tco95ttocs » Thu 15 Sep 2016 09:52

i found the error. It was a spelling error in the appconfig.
So now everything works fine :)
Thx for the deployment-link
tco95ttocs
 
Posts: 5
Joined: Wed 20 Apr 2016 06:56


Return to dotConnect for PostgreSQL