Work with SSAS

Work with SSAS

Postby moonpie » Mon 09 Nov 2015 16:08

Hi!
I've downloaded trial version of your driver in order to test possibility to switch to it. We use SSAS in our environment as OLAP-solution and Postgresql as DWH.
I have a few questions and I wonder you can answer on it.
1. If I add any table into DataSourceView while I'm designing database it always runs query against this table and retrieves all rows it contains. If we're talking about dimensions with several thousand rows then it's OK, but when I try to add fact table with several hundred million records, IDE hangs up totally. I tried to change "Default FetchAll" option to False, no luck though. Can this query be disabled any way?
2. I added empty fact table into DSV, created OLAP-cube with several dimensions, after that I filled this table with some data and tried to process cube. After 10 minutes OutOfMemory exception appeared. The same amount of data was processed using MS SQL datasource and PGOLEDB driver as well. Can I change driver's behaviour and not to consume all rows in one batch?
Thanks.
moonpie
 
Posts: 4
Joined: Mon 09 Nov 2015 15:54

Re: Work with SSAS

Postby Shalex » Thu 12 Nov 2015 18:43

moonpie wrote:1. If I add any table into DataSourceView while I'm designing database it always runs query against this table and retrieves all rows it contains. If we're talking about dimensions with several thousand rows then it's OK, but when I try to add fact table with several hundred million records, IDE hangs up totally. I tried to change "Default FetchAll" option to False, no luck though. Can this query be disabled any way?
1. Looks like DataSourceView doesn't use CommandBehavior.SchemaOnly explicitly when you add a table to it. If DataSourceView requires all records, this forces the provider to retrieve all records from the database. Does PGOLEDB driver behave in a different way?

moonpie wrote:2. I added empty fact table into DSV, created OLAP-cube with several dimensions, after that I filled this table with some data and tried to process cube. After 10 minutes OutOfMemory exception appeared. The same amount of data was processed using MS SQL datasource and PGOLEDB driver as well. Can I change driver's behaviour and not to consume all rows in one batch?
2.1. Try adding "Default Fetch All=false;" in your connection string. Does this help?
2.2. Try using the "UnpreparedExecute=true;" connection string option. Does this make any difference?
Shalex
Devart Team
 
Posts: 7660
Joined: Thu 14 Aug 2008 12:44

Re: Work with SSAS

Postby moonpie » Mon 16 Nov 2015 10:43

Looks like PGOLEDB driver does not query table at all, just retrieves its structure.
Setting options as suggested above didn't resolve problem, still have the same problem
moonpie
 
Posts: 4
Joined: Mon 09 Nov 2015 15:54

Re: Work with SSAS

Postby Pinturiccio » Mon 16 Nov 2015 15:05

Thank you for the provided information sent by email. We are investigating it and will post here about the results as soon as possible.
Pinturiccio
Devart Team
 
Posts: 1986
Joined: Wed 02 Nov 2011 09:44

Re: Work with SSAS

Postby Pinturiccio » Wed 16 Dec 2015 09:14

We have reproduced and fixed the bug with tables having lots of data in SSAS projects. We will post here when the corresponding build of dotConnect for PostgreSQL is available for download.
Pinturiccio
Devart Team
 
Posts: 1986
Joined: Wed 02 Nov 2011 09:44

Re: Work with SSAS

Postby moonpie » Wed 16 Dec 2015 10:16

Great news!
Looking forward to try updated version of your driver
moonpie
 
Posts: 4
Joined: Mon 09 Nov 2015 15:54

Re: Work with SSAS

Postby Pinturiccio » Mon 21 Dec 2015 10:39

New build of dotConnect for PostgreSQL 7.4.558 is available for download now!
It can be downloaded from http://www.devart.com/dotconnect/postgresql/download.html (trial version) or from Registered Users' Area (for users with valid subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?t=32922
Pinturiccio
Devart Team
 
Posts: 1986
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for PostgreSQL