Why Could not load type 'Devart.Data.PostgreSql.Web.Providers.PgSqlExtendedRoleProvider?

Why Could not load type 'Devart.Data.PostgreSql.Web.Providers.PgSqlExtendedRoleProvider?

Postby Husniddin » Fri 04 Sep 2015 08:32

Hi,

I'm using this tutorial https://www.devart.com/dotconnect/postgresql/docs/?AspProviders.html
for Using ExtendedMembership Provider in ASP.NET MVC 4 Application. When I'm in STEP:5 , after adding code in web.config Visual Studio shows Error. :?

Error:
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load type 'Devart.Data.PostgreSql.Web.Providers.PgSqlExtendedRoleProvider' from assembly 'Devart.Data.PostgreSql.Web, Version=7.4.478.0, Culture=neutral, PublicKeyToken=09af7300eec23701'.

    Source Error:
    Line 32: <providers>
    Line 33: <remove name="PgSqlExtendedRoleProvider"/>
    Line 34: <add name="PgSqlExtendedRoleProvider" type="Devart.Data.PostgreSql.Web.Providers.PgSqlExtendedRoleProvider,
    Line 35: Devart.Data.PostgreSql.Web, Version=7.4.478.0, Culture=neutral, PublicKeyToken=09af7300eec23701" description="dotConnect for PostgreSQL extended role provider" connectionStringName="DefaultConnection"/>
    Line 36: </providers>

I've already added Devart.Data.PostgreSql.Web assembly in references folder.

What's wrong here??
Husniddin
 
Posts: 8
Joined: Mon 10 Aug 2015 08:26

Re: Why Could not load type 'Devart.Data.PostgreSql.Web.Providers.PgSqlExtendedRoleProvider?

Postby Pinturiccio » Mon 07 Sep 2015 12:57

The link you specified leads to the ASP.NET 2.0 Provider Model tutorial and it does not have step 5. Perhaps, you meant the following tutorial
https://www.devart.com/dotconnect/postgresql/docs/?ExtendedMembership-Tutorial.html?

There are several assemblies of Devart.Data.PostgreSql.Web.dll. According to step 2 of this tutorial, you need version 7.4.478.4 of the Devart.Data.PostgreSql.Web assembly, not version 7.4.478.0. This must be specified in config, and this version of the assembly (ending 4) should be added to references. Also, the assembly ending 4 is specified in step 5.

Please post here whether changing assembly version from 7.4.478.0 to 7.4.478.4 fixes the issue.
Pinturiccio
Devart Team
 
Posts: 1979
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for PostgreSQL