PostgreSQLDirect causing VSNet 2005 startup issues

PostgreSQLDirect causing VSNet 2005 startup issues

Postby NeilL » Fri 03 Mar 2006 02:51

After working with the Microsoft VSNet 2005 team for several days off and on I have figured out that installing PostgreSQLDirect .NET 2.40 for .NET Framework 2.0 results in initialization and shutdown errors in VSNet. While there are no error dialogs displayed the problem symptom is that adding a tool bar to the IDE is not saved in the configuration file and so is not being restored when the IDE is restarted. After uninstalling the PostgreSQL product the VSNet IDE again behaves as expected.

I was using the trial version so perhaps the latest version of the product and/or the licensed version corrects this issue.

Has anyone else seen this problem?

Any suggestions?
NeilL
 
Posts: 4
Joined: Fri 03 Mar 2006 02:45

Postby SecureGen » Fri 03 Mar 2006 09:35

To fix the problem after you install PostgreSQLDirect .NET try removing its addin. To do this delete from registry the following key:
HKEY_CURRENT_USER\SoftWare\Microsoft\VisualStudio\8.0\AddIns\CoreLab.PostgreSql.Addin.PgSqlAddin.8
HKEY_LOCALMACHINE\SoftWare\Microsoft\VisualStudio\8.0\AddIns\CoreLab.PostgreSql.Addin.PgSqlAddin.8
This is the only possible reason for the problem.
Note that after uninstalling the addin you will not have access to PostgreSQLDirect .NET menu in the IDE
SecureGen
Devart Team
 
Posts: 133
Joined: Thu 08 Sep 2005 06:27

Postby NeilL » Fri 03 Mar 2006 16:14

Thanks for the reply.

I removed the key (was only in the "LOCALMACHINE" hive and it seemed to resolve the issue for me. I can now get the toolbars to stick as expected.

Obviously would like to be able to get to the PostgreSQLDirect menu of course so I hope someone looks into the issue.
NeilL
 
Posts: 4
Joined: Fri 03 Mar 2006 02:45

Postby NeilL » Tue 25 Apr 2006 02:15

I'm having the same issue with the current version (2.5). It was working properly for a time then started doing the same thing. Same registry keys for turning this "feature" off?

Thanks
NeilL
 
Posts: 4
Joined: Fri 03 Mar 2006 02:45

Postby Alexey » Tue 25 Apr 2006 15:39

Yes, try to perform the same actions.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby NeilL » Tue 25 Apr 2006 15:51

Did and it again solves my issue, thanks.

Any idea what the problem really is here as I'd love to be able to use the provided menu support

Neil
NeilL
 
Posts: 4
Joined: Fri 03 Mar 2006 02:45


Return to dotConnect for PostgreSQL