Crital Error after upgrad to Version 6.8.333.0

Crital Error after upgrad to Version 6.8.333.0

Postby peri » Mon 14 Oct 2013 06:22

Hi All

I have just upgraded to version 6.8.333.0 as soon as I try to compil my solution I get the following message:

Error 11 Error 4: Could not load file or assembly 'Devart.Data.PostgreSql.Entity, Version=6.8.333.0, Culture=neutral, PublicKeyToken=09af7300eec23701' or one of its dependencies. The system cannot find the file specified.

I have already search my system for that assembly it is missing, so can add direct reference or copy it to my bin directory.

My next step was to install the new version on "clean machine" with no need for upgrade.
Open the solution on that machine result with the same problem.

Any help or idea is most appreciated !!
peri
 
Posts: 4
Joined: Thu 25 Jul 2013 11:49

Re: Crital Error after upgrad to Version 6.8.333.0

Postby Shalex » Mon 14 Oct 2013 08:51

Please check the edition of your current version of dotConnect for PostgreSQL. You can do that via the Tools > PostgreSQL > About menu of Visual Studio.

Be aware that the Entity Framework support is available only in the Professional Edition of dotConnect for PostgreSQL: http://www.devart.com/dotconnect/postgresql/editions.html.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for PostgreSQL