How to install dotConnect for both PostgreSQL and SQLIte

How to install dotConnect for both PostgreSQL and SQLIte

Postby sathish.infotech » Wed 22 May 2013 06:25

Hi,

I have installed Devart dotConnect for PostgreSQL (5.60.350) in my system and developed an sample app. All what I did was, copied the Devart.Data.dll, Devart.Data.Linq.dll, Devart.Data.PostgresSQL.dll and Devart.Data.PostgreSQL.Linq.dll from ProgramFiles/Common/Devart/5.0/ to local folder where the app resides and referred these dll's from the local folder.
Now in order to support dotConnect for SQLite, I have downloaded trial version of SQLite and installed the same. While installation I get an error saying "Already older version of Devart.Data.dll (this is for PostgreSQL) is available in GAC. Do you still want to continue". So I clicked continue anyway. And same got installed.

Now without doing any changes in references, I ran the sample app, but I get an exception something like "Void method not found... ..ctor" while trying to make which says that Constructor not found.

then uninstalled both SQLite and PostgreSQL, then only the app started working without any error.

Please suggest me better way so that I can have dotConnect for both PostgreSQL and SQLLite in same machine. So that I can refer both the components in my app so that it can support both the datasources based on config changes.
sathish.infotech
 
Posts: 3
Joined: Sun 19 May 2013 05:21

Re: How to install dotConnect for both PostgreSQL and SQLIte

Postby Pinturiccio » Fri 24 May 2013 14:15

sathish.infotech wrote:I have installed Devart dotConnect for PostgreSQL (5.60.350)

Probably you meant version 5.80.350 of dotConnect for PostgreSQL, as version 5.60.350 of dotConnect for PostgreSQL does not exist.

All Devart data providers use a common assembly (Devart.Data.dll). We release our ADO.NET data providers simultaneously, thus releases with the same date are compatible. The compatibility of providers depends on their release date.

In your case, dotConnect for PostgreSQL uses one Devart.Data.dll assembly version, and dotConnect for SQLite uses another Devart.Data.dll version. You should install compatible versions. For this, do either of the following:
1. Either install dotConnect for SQLite 3.80.350 compatible with dotConnect for PostgreSQL 5.80.350.
2. Or upgrade dotConnect for PostgreSQL to the latest version 6.6.242 and use it with dotConnect for SQLite 4.6.242.

For more information, please refer to
http://www.devart.com/dotconnect/sqlite/revision_history.html
http://www.devart.com/dotconnect/postgresql/revision_history.html
Pinturiccio
Devart Team
 
Posts: 1978
Joined: Wed 02 Nov 2011 09:44

Re: How to install dotConnect for both PostgreSQL and SQLIte

Postby sathish.infotech » Fri 24 May 2013 16:56

Hi,

Thanks for your reply.

Please help me on downloading the SQLite Version 3.80.350.
Provide me details on where and how to download and also the pricing details.

Thanks,
Sathish

.
sathish.infotech
 
Posts: 3
Joined: Sun 19 May 2013 05:21

Re: How to install dotConnect for both PostgreSQL and SQLIte

Postby Shalex » Mon 27 May 2013 08:35

Please contact our Sales department (sales at devart*com) and specify the e-mail you have used when registering the product.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for PostgreSQL