complex query works in 5.50.237 but not from 5.70.311

complex query works in 5.50.237 but not from 5.70.311

Postby kerrywales » Sat 10 Mar 2012 09:52

I have a query from a single table but lots of "let" statements similar to

var CalcQuery = from Branch in entity.Branch
.....
select new
{
....
}

foreach (var Branch in CalcQuery)
{
....
}


let varVatTotals = Branch.TblJobHeads.Sum(o => o.TblAccounts.VAT != null ? o.TblAccounts.VAT: 0M)

This is followed by a foreach to process each record. When starting the


This worked fine with

5.50.237

I have just updated to 5.70.311. Same code that worked now produces an error

System.Data.EntityCommandExecutionException: An error occurred while executing the command definition. See the inner exception for details. ---> Devart.Data.PostgreSql.PgSqlException: column Project8.C2 does not exist

The error refers to an internally created column, not one of mine.

I have tried to uninstall 5.70 to go back to 5.50. This is causing problems when 5.50 installs. So I have two issues.

1. Anyone else seen a similar issue and can guide me to a work around?
2. Should I need to do something when uninstalling 5.70 to reinstall 5.50 because using the standard uninstall/install is failing.

My dev PC is Vista 32 bit.
kerrywales
 
Posts: 52
Joined: Tue 05 Jan 2010 12:26

Postby MariiaI » Tue 13 Mar 2012 12:59

The problem with installation may occur since some assemblies of the newer version were not deleted.
Try to do the following steps:
- uninstall dotConnect for PostgreSQL( and the other Devart product(s), if you have installed any of them);
- remove all Devart.* and policy.*.Devart.* files from the GAC;
- clear the Program Files\Devart\dotConnect and Program Files\Common Files\Devart\dotConnect folders;
- install dotConnect for PostgreSQL version 5.50.

As for the problem with the query, could you please send us the script for creating the database objects you are working with and the exact LINQ query text.
If possible, please send a test project with which the issue can be reproduced.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Postby kerrywales » Wed 14 Mar 2012 11:26

Thank you. I will try the removal. I now know one of my colleagues has already reported the issue to you and is awaiting a reply on another thread.

Regards
kerrywales
 
Posts: 52
Joined: Tue 05 Jan 2010 12:26

Postby kerrywales » Wed 14 Mar 2012 12:27

Followed your instructions. Got error dialog boxes whilst installing older version.

Modules which are not in the manifest were streamed in (Exception from HRESULT: 0x80131043)
Please contact Devart support team

The Install.log is as follows
--- Custom action error: CrGacUtil
Date: 14/03/2012 12:24:01
Environment
Operating System: Microsoft Windows NT 6.0.6002 Service Pack 2
.NET Framework: 2.0.50727.4216
Assembly: CrGacUtil, Version=1.0.0.0, Culture=neutral, PublicKeyToken=09af7300eec23701
Exception
Message: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Type: Devart.Common.Setup.CustomActionException
StackTrace: at CrGacUtil.Program.Main(String[] args)
CustomMessage: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Inner Exception
Message: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Type: Devart.Common.Setup.CustomActionException
StackTrace: at CrGacUtil.Program.Main(String[] args)

--- Custom action error: CrGacUtil
Date: 14/03/2012 12:25:27
Environment
Operating System: Microsoft Windows NT 6.0.6002 Service Pack 2
.NET Framework: 2.0.50727.4216
Assembly: CrGacUtil, Version=1.0.0.0, Culture=neutral, PublicKeyToken=09af7300eec23701
Exception
Message: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Type: Devart.Common.Setup.CustomActionException
StackTrace: at CrGacUtil.Program.Main(String[] args)
CustomMessage: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Inner Exception
Message: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Type: Devart.Common.Setup.CustomActionException
StackTrace: at CrGacUtil.Program.Main(String[] args)

--- Custom action error: CrGacUtil
Date: 14/03/2012 12:25:30
Environment
Operating System: Microsoft Windows NT 6.0.6002 Service Pack 2
.NET Framework: 2.0.50727.4216
Assembly: CrGacUtil, Version=1.0.0.0, Culture=neutral, PublicKeyToken=09af7300eec23701
Exception
Message: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Type: Devart.Common.Setup.CustomActionException
StackTrace: at CrGacUtil.Program.Main(String[] args)
CustomMessage: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Inner Exception
Message: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Type: Devart.Common.Setup.CustomActionException
StackTrace: at CrGacUtil.Program.Main(String[] args)

--- Custom action error: CrGacUtil
Date: 14/03/2012 12:25:32
Environment
Operating System: Microsoft Windows NT 6.0.6002 Service Pack 2
.NET Framework: 2.0.50727.4216
Assembly: CrGacUtil, Version=1.0.0.0, Culture=neutral, PublicKeyToken=09af7300eec23701
Exception
Message: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Type: Devart.Common.Setup.CustomActionException
StackTrace: at CrGacUtil.Program.Main(String[] args)
CustomMessage: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Inner Exception
Message: Modules which are not in the manifest were streamed in. (Exception from HRESULT: 0x80131043)
Type: Devart.Common.Setup.CustomActionException
StackTrace: at CrGacUtil.Program.Main(String[] args)
kerrywales
 
Posts: 52
Joined: Tue 05 Jan 2010 12:26

Postby Shalex » Thu 15 Mar 2012 18:02

kerrywales wrote:I have just updated to 5.70.311. Same code that worked now produces an error

System.Data.EntityCommandExecutionException: An error occurred while executing the command definition. See the inner exception for details. ---> Devart.Data.PostgreSql.PgSqlException: column Project8.C2 does not exist

Please refer to http://www.devart.com/forums/viewtopic.php?t=23532.

kerrywales wrote:Got error dialog boxes whilst installing older version.

Modules which are not in the manifest were streamed in (Exception from HRESULT: 0x80131043)

We cannot reproduce the issue in our environment. Usually it occurs if assemblies/policy files from higher version are left in GAC. Please ignore this message. Is workability of the 5.50.237 version OK in this case?
Shalex
Devart Team
 
Posts: 7792
Joined: Thu 14 Aug 2008 12:44

Postby kerrywales » Mon 19 Mar 2012 19:44

I have now managed an installation of 5.50. This now correctly processes the query.

I hope you can resolve the issue in 5.70/5.80 soon.

Regards
kerrywales
 
Posts: 52
Joined: Tue 05 Jan 2010 12:26

Postby Shalex » Fri 23 Mar 2012 11:22

The bug with using expression aliases in complex queries is fixed. We will post here when the corresponding build of dotConnect for PostgreSQL is available for download.
Shalex
Devart Team
 
Posts: 7792
Joined: Thu 14 Aug 2008 12:44

Postby Shalex » Thu 29 Mar 2012 15:56

New build of dotConnect for PostgreSQL 5.80.332 is available for download now!
It can be downloaded from http://www.devart.com/dotconnect/postgr ... nload.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=23777 .
Shalex
Devart Team
 
Posts: 7792
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for PostgreSQL