connect to postgresql in visual studio

connect to postgresql in visual studio

Postby overtime » Fri 04 Nov 2011 13:40

Hallo,

when I want to enter a new database connection in VS Express 2010 using dotConnect, I can only enter the connection string. However, if I enter the connection string as I found here: http://www.connectionstrings.com/postgre-sql
there is an error message saying: "Unknown connection string parameter. Parametername: value"
What am I doing wrong?
overtime
 
Posts: 3
Joined: Fri 04 Nov 2011 09:44

Postby Pinturiccio » Mon 07 Nov 2011 10:24

overtime wrote:when I want to enter a new database connection in VS Express 2010 using dotConnect, I can only enter the connection string.

It is the correct behaviour, when only PgSqlConnectionString property is available at design time in VS Express: http://www.devart.com/dotconnect/postgr ... ility.html
overtime wrote:However, if I enter the connection string as I found here: http://www.connectionstrings.com/postgre-sql
there is an error message saying: "Unknown connection string parameter. Parametername: value"

The class PgSqlConnection does not consider such parameter as Value. You can use our documentation to see the
parameters allowed in the connection string http://www.devart.com/dotconnect/postgresql/docs/ . If this doesn't help, post your connection string (roughly, without credentials) here.
Pinturiccio
Devart Team
 
Posts: 2020
Joined: Wed 02 Nov 2011 09:44

Postby overtime » Mon 07 Nov 2011 15:57

Hallo,
thanks for your reply. As mentionned, I can only enter the connection string. For me it looks like this:

User ID=postgres;Password=admin;Host=localhost;Port=5432;Database=testDB; Pooling=true;Min Pool Size=0;Max Pool Size=100;Connection Lifetime=0;

If I enter this connection string, I get the previously mentionned error message.

I don't know what to do. Thank you for your help.
overtime
 
Posts: 3
Joined: Fri 04 Nov 2011 09:44

Postby Pinturiccio » Tue 08 Nov 2011 09:53

We could not reproduce your issue with VS Express 2010 and dotConnect for PostgreSQL Express 5.50.237. Please send us the following information to help us reproduce the issue:

1. Where did you exactly enter the connection string?
2. What version and edition of dotConnect for PostgreSQL do you use?
3. Please send us the steps that lead to this exception.
Pinturiccio
Devart Team
 
Posts: 2020
Joined: Wed 02 Nov 2011 09:44

Postby overtime » Tue 08 Nov 2011 16:38

1. Add Connection - Properties (see 3.)
2. I have the latest version (I guess 5.50) which I downloaded last friday, it's dotconnect postgresql express
3. I click on New Connection in the database explorer, then I enter postgre SQL server as data source and select dotConnect for postgreSQL. In the next window I can define properties (in this case just one: Connection String), Test Connection completes successfully (even if I enter no connection string), after clicking on OK, the message occurs

@edit: As I tried to reproduce it now, I get a different message: File or assembly "Devart.Data, Version =5.0.336.0, Culture = neutral, PublicKeyToken=09af7300eec23701" or one of its dependencies cannot be found
overtime
 
Posts: 3
Joined: Fri 04 Nov 2011 09:44

Postby Pinturiccio » Wed 09 Nov 2011 12:46

overtime wrote:there is an error message saying: "Unknown connection string parameter. Parametername: value"


We have reproduced the issue with the error message: "Unknown connection string parameter. Parametername: value". We will investigate the issue and notify you about the results as soon as possible.

overtime wrote:As I tried to reproduce it now, I get a different message: File or assembly "Devart.Data, Version =5.0.336.0, Culture = neutral, PublicKeyToken=09af7300eec23701" or one of its dependencies cannot be found


Perform the following steps:
1. uninstall dotConnect for PostgreSQL;
2. remove all Devart.* and policy.*.Devart.* files from the GAC;
3. clear the Program Files\Devart\dotConnect and Program Files\Common Files\Devart\dotConnect folders;
4. re-install dotConnect for PostgreSQL.
Pinturiccio
Devart Team
 
Posts: 2020
Joined: Wed 02 Nov 2011 09:44

Postby Pinturiccio » Wed 04 Jan 2012 11:31

We are working on the issue with Visual Studio Web Developer Express. We can offer you a workaround.
If the \Program Files\Microsoft Visual Studio 10.0\Common7\IDE\VWDExpress.exe.config file exists, then you have to add the following entries to the element.
Code: Select all
   
       
/>
       
     

     
       
/>
       
     

     
       
culture="neutral" />
       
     

     
       
culture="neutral" />
       
     

     
       
culture="neutral" />
       
     


If you do not have \Program Files\Microsoft Visual Studio 10.0\Common7\IDE\VWDExpress.exe.config, you should create it and enter the following information:
Code: Select all


 
   
     
       
/>
       
     

     
       
/>
       
     

     
       
culture="neutral" />
       
     

     
       
culture="neutral" />
       
     

     
       
culture="neutral" />
       
     

   

 


Pinturiccio
Devart Team
 
Posts: 2020
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for PostgreSQL