Problem with Entity Developer

Problem with Entity Developer

Postby TonyV » Wed 25 May 2011 15:13

I have a PostgreSQL database with one schema in it (other than public). The schema includes the definitions of 2 composite types that are used as the return values for 2 different stored functions.

In the script where I create these types, they are clearly defined as belonging to my schema. That is, the statement begins with CREATE TYPE "MySchema"."MyType". I've triple checked the code & I'm not seeing things.

Yet, the Entity developer is giving me an error that says, "The Type MyType is not qualified with a namespace or alias. Only PrimitiveTypes can be used without qualification." This makes no sense as the types are in a schema.

I've got 9 days left of my evaluation & this is the only tool for PostgreSQL I've found that actually seems to work. I've got to get this entity model working today of we're going to have to look elsewhere for a solution. Any help is greatly appreciated.

Tony
TonyV
 
Posts: 74
Joined: Wed 25 May 2011 15:03

Postby AndreyR » Tue 31 May 2011 12:09

We are unable to add support for PostgreSQL user-defines types in Entity Framework. The reason is the fact that Entity Framework is able to work only with primitive DB types.
There are some workarounds like the PostGIS workaround or the Composite types workaround, however.
As for the LinqConnect models, we are investigating the possibility to add this functionality. You can influence our road map using Devart LinqConnect User Voice - feel free to add a suggestion and vote for the existing ones.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby TonyV » Tue 31 May 2011 15:01

Thanks for your reply. I was able to work around this error. The schema includes some functions that aren't used by the application I have to build (they're used elsewhere in our system, but not by this particular app). The composite types are the return types for these stored functions.

So I rebuilt the model, but didn't choose to include the functions. This got rid of the error entirely.

Thanks again for your reply.

Tony
TonyV
 
Posts: 74
Joined: Wed 25 May 2011 15:03


Return to dotConnect for PostgreSQL