SSL Allow mode doesn't work properly + bug in PgSqlException

SSL Allow mode doesn't work properly + bug in PgSqlException

Postby belidzs » Fri 10 Dec 2010 15:20

Hi

I'm using v4.95.170.0
My server (8.4) is set to require SSL, but even if I set PgSqlConnection.SslOptions.SslMode = Allow, it doesn't try to use SSL, but it throws an exception.

An other bug: using SSL mode, if wrong password is used, PgSqlExceltion has a meaningless "transport channel is closed" message.
belidzs
 
Posts: 29
Joined: Wed 30 Sep 2009 12:07

Postby StanislavK » Tue 14 Dec 2010 17:09

Concerning the problem with SslMode.Allow, could you please specify the exact message and the stack trace of the exception you are getting?

As for the "Transport channel is closed" error, we will consider the possibility of throwing more informative exception when authentication fails. We will inform you about the results of our investigation here.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Postby StanislavK » Tue 28 Dec 2010 17:05

We have reproduced and fixed the problem with connecting in the 'Allow' SSL mode.

As for the error text, the problem is that the server closes the connection without a message when an SSL connection attempt fails. We have changed the message to "Authentication failed in ssl mode." for this case, but further detail is not possible.

These changes will be available in the nearest build which we plan to release in a week or two.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Postby belidzs » Wed 05 Jan 2011 17:16

StanislavK wrote:We have reproduced and fixed the problem with connecting in the 'Allow' SSL mode.

As for the error text, the problem is that the server closes the connection without a message when an SSL connection attempt fails. We have changed the message to "Authentication failed in ssl mode." for this case, but further detail is not possible.

These changes will be available in the nearest build which we plan to release in a week or two.


Thank you, this is going to solve my problem.

Balázs
belidzs
 
Posts: 29
Joined: Wed 30 Sep 2009 12:07

Postby StanislavK » Wed 12 Jan 2011 17:14

We have released the 5.0.86 build of dotConnect for PostgreSQL. The new build can be downloaded from
http://www.devart.com/dotconnect/postgresql/download.html
(the trial version) or from Registered Users' Area (for users with active subscription only):
http://secure.devart.com/

For the detailed information about the fixes and improvements available in this build, please refer to
http://www.devart.com/forums/viewtopic.php?t=19970
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48


Return to dotConnect for PostgreSQL