Unsupported frontend protocol

Unsupported frontend protocol

Postby zaheerd » Tue 11 May 2010 08:53

Hi
Im getting a strange error when trying to connect to one of our postgres databases using dotConnect. i get the following error "Unsupported frontend protocol" The server is running postgres version 7.3.4 and im using the latest version of dotconnect for postgres.

I can connect using pgAdmin and other DB tools, just not dotconnect.

Any help would be appreciated.

TIA
zaheerd
 
Posts: 2
Joined: Tue 11 May 2010 08:48

Postby StanislavK » Wed 12 May 2010 09:30

Thank you for your report. This is a known issue of working with older PostgreSQL databases using the latest version of dotConnect for PostgreSQL. The problem is fixed and the fix will be available in the nearest build.

At the moment, there is no workaround for this problem at design-time. However, connecting to PostgreSQL servers of version 7.3 should work at run-time.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Postby zaheerd » Wed 12 May 2010 09:37

Hi,
I've tried connecting to the DB at runtime but i still get the unsupported error.
is there any property that i need to set on the pgConnect component to get it to work at runtime?

here is a sample of the connection string im using
server=127.0.0.1;port=5434;database=testdb;user=postgres;password=postgres


Thanks
zaheerd
 
Posts: 2
Joined: Tue 11 May 2010 08:48

Postby StanislavK » Fri 14 May 2010 14:09

Please add the 'Protocol' property to the connection string and set it to 'Ver20'. Older versions of PostgreSQL work with text protocol 2.0. Servers of version 7.4 and higher use the binary 3.0 protocol which is the default option in dotConnect for PostgreSQL. For details, please see the Protocol property of connection string in the corresponding topic of our documentation.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48


Return to dotConnect for PostgreSQL