Generating Entity with Pre-Generated Views = true

Generating Entity with Pre-Generated Views = true

Postby stephen.Cognito » Mon 18 Jan 2010 10:59

Hi

We are trying to build an Entity Model with the property 'View Generation' = true set. When saving and returning to VS2008, the IDE goes through the process of adding the new entity files and then crashes when adding the Pre-Generated View file. We have successfully generated a model with this property set when this functionality first became available but subsequent version updates have proved unsuccessful.

We are using version 4.65.62 [16 Dec 2009] dotConnect for PostgreSQL

Any help would be appreciated
Many thanks

Stephen
stephen.Cognito
 
Posts: 10
Joined: Mon 18 Jan 2010 10:48
Location: Devon, UK

Postby AndreyR » Mon 18 Jan 2010 13:21

The similar problem was already discussed at Microsoft blog here:
http://beta.blogs.microsoft.co.il/blogs ... fixup.aspx
This is a problem of Entity Framework v1, it is fixed in EF v4.
Unfortunately, we still don't offer support for EF v4 in our Entity Developer.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby Dave5709 » Tue 02 Feb 2010 18:04

When do you think you'll offer support for EF v4?
Dave5709
 
Posts: 3
Joined: Fri 18 Dec 2009 21:12
Location: Sacramento, CA, USA

Postby StanislavK » Wed 03 Feb 2010 10:38

The basic support for Entity Framework v4, including support for Microsoft EDM Wizard, is available in the current build. However, Devart Entity Developer integration with Visual Studio 2010 Beta 2 still doesn't work.

The full support of EF v4 Beta 2 will be available in the nearest Beta build. We plan to release it next week.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48


Return to dotConnect for PostgreSQL