MembershipProvider and paging

MembershipProvider and paging

Postby alex_caro1 » Fri 02 Oct 2009 15:18

Hi,

I have a problem with paging in the function GetAllUsers from MembershipProvider:
MembershipProvider.GetAllUsers(0, 10, out totalUserCount);

I would expect to get only the first ten users of my system but I get all users.
Am I doing something wrong there?

Regards,
Alexandra
alex_caro1
 
Posts: 6
Joined: Fri 02 Oct 2009 15:10

Postby Shalex » Mon 05 Oct 2009 16:32

We have reproduced the issue. We will investigate it and notify you about the results as soon as possible.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Postby Shalex » Fri 09 Oct 2009 15:19

The problem is fixed. Look forward to the next build of dotConnect for PostgreSQL. I will post here when it is available for download.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Postby alex_caro1 » Mon 12 Oct 2009 07:00

Thanks, I'm looking forward to testing it.
alex_caro1
 
Posts: 6
Joined: Fri 02 Oct 2009 15:10

Postby Shalex » Tue 20 Oct 2009 09:45

The new build of dotConnect for PostgreSQL 4.55.49 is available for download now.
It can be downloaded from http://www.devart.com/dotconnect/postgr ... nload.html (trial version) or from Registered Users' Area (for users with valid subscription only).
For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=16153 .
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Postby alex_caro1 » Tue 27 Oct 2009 12:41

Hi,

I just installed dotConnect 4.55.49.

Unfortunately the paging problem is still there:

the call to

MembershipProvider.GetAllUsers(0, 10/*pageSize*/, out totalUserCount);

still returns the total number of users instead of 10.

Regards,
Alexandra
alex_caro1
 
Posts: 6
Joined: Fri 02 Oct 2009 15:10

Postby Shalex » Wed 28 Oct 2009 11:10

I cannot reproduce the problem with the 4.55.49 version of dotConnect for PostgreSQL. Please make sure that the 4.55.49.0 version of Devart.Data.PostgreSql.Web.dll is loaded to the process of your application. You can check it by launching the Debug | Windows | Modules window when running your application in the debug mode and setting a break point somewhere in your code.

Please notify us about the results.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Postby alex_caro1 » Tue 03 Nov 2009 11:59

Hi,

I think there is a problem with the installer package.

The visual studio reference properties shows Devart.Data.PostgreSql.Web 4.55.49.
But in the module window, when the application is running, it shows 4.55.42.

I already try to reinstall it, then re-add the devart references, but I still see the wrong dll version although I don't have any old version of Devart on my computer anymore.

Thanks for your help,
Alexandra
alex_caro1
 
Posts: 6
Joined: Fri 02 Oct 2009 15:10

Postby Shalex » Wed 04 Nov 2009 08:39

1. Please check all references in your project (in the *.config and *.aspx files).
2. Make sure that there is no Devart.Data.PostgreSql.Web.dll 4.55.42 in your GAC and in the bin folder of your project.
3. Please try re-adding the references to the Devart assemblies again.

If the problem persists, let us know.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Postby alex_caro1 » Wed 04 Nov 2009 09:22

Hi,

ok, I am now using the right dlls and the problem mentioned above is solved.

But the paging still doesn't work:

Old version:
MembershipProvider.GetAllUsers(0, 10/*pageSize*/, out totalUserCount)
returns a user collection with 50 users (all).

New version (4.55.49):
MembershipProvider.GetAllUsers(0, 10/*pageSize*/, out totalUserCount)
returns a user collection with only 10 users but now totalUserCount is also equal to 10 instead of 50.

Regards,
Alexandra
alex_caro1
 
Posts: 6
Joined: Fri 02 Oct 2009 15:10

Postby Shalex » Thu 05 Nov 2009 14:00

Thank you for your report. We will fix the issue.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Postby Shalex » Fri 06 Nov 2009 15:50

The problem with the MembershipProvider.GetAllUsers method is fixed. Look forward to the next build of dotConnect for PostgreSQL. I will post here when it is available for download.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Postby Shalex » Fri 20 Nov 2009 16:25

dotConnect for PostgreSQL v 4.65 is released.
It can be downloaded from http://www.devart.com/dotconnect/postgresql/download.html (trial version) or from Registered Users' Area (for users with valid subscription only).
For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=16438.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Postby alex_caro1 » Wed 25 Nov 2009 13:30

Hi,

I installed the last release of dotConnect for PostgreSQL (v 4.65).

And I am sorry to say that it is still not working. The previous problem has been fixed, but the paging is still wrong.

Older version:
MembershipProvider.GetAllUsers(0, 10/*pageSize*/, out totalUserCount)
returns a user collection with 50 users (all).

Version 4.55.49:
MembershipProvider.GetAllUsers(0, 10/*pageSize*/, out totalUserCount)
returns a user collection with only 10 users but now totalUserCount is also equal to 10 instead of 50.

Version 4.65:
MembershipProvider.GetAllUsers(0, 10/*pageSize*/, out totalUserCount)
returns a user collection with only 10 users and totalUserCount is equal to 50. This is correct.
But now the problem is that I don't get the right user values!
For page 0, I get user0, ..., user10.
For page 1, I get user0, ..., user9, user11.
(The users are not sorted by name)

Thanks for your help,
Alexandra
alex_caro1
 
Posts: 6
Joined: Fri 02 Oct 2009 15:10

Postby Shalex » Thu 26 Nov 2009 11:30

Thank you. We will fix the paging and send you a separate Devart.Data.PostgreSql.Web.dll assembly where the problem is resolved to your e-mail address.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44

Next

Return to dotConnect for PostgreSQL