Bug with reading UNICODE in new version

Bug with reading UNICODE in new version

Postby Joern » Mon 13 Jun 2005 20:45

I just installed the latest version 2.10.7 and I cannot read UNICODE from my database anymore. (Database version 8.0.3 on Windows)

It seems that I can write Unicode characters to the database. When I look at the data in pgAdmin it looks ok. However, the data that is returned to my application is scrambled.

As soon as I remove the new version and install the old version 2.10.3 everything works as expected.

Regards,

Joern


P.S.: Sorry, I do not have the versions between 2.10.3 and 2.10.7 - therefore I cannot tell exactly which version broke the code. If you have a download link for the older versions I will try them.
Joern
 

Bug with reading UNICODE in new version

Postby Yuri » Thu 16 Jun 2005 10:29

Please specify a code sample to open connection and Encoding option at the server.
Have you set PgSqlConnection.Charset property after PgSqlConnection.Unicode?
Yuri
 
Posts: 140
Joined: Mon 08 Nov 2004 12:07

Encoding options

Postby Joern » Wed 22 Jun 2005 15:01

I do not set Charset property. I set Unicode=true. (I tried setting Unicode in the connection string and in code but without a difference.)

I have the following encoding options for the database:

PostgreSQL (8.0.3) general:

Locale = German, Germany
Encoding = LATIN1

Database option (when creating database)

Encoding = UNICODE

As I wrote before: As soon as I deinstall the new version and install an old version (2.10.4) everything is correct. (With the same database and encoding options of course.)

Regards,

Joern
Joern
 

Bug with reading UNICODE in new version

Postby Yuri » Thu 23 Jun 2005 10:12

We reproduced problem and fixed it. This fix will be included in the next PostgreSQLDirect .NET build.
Yuri
 
Posts: 140
Joined: Mon 08 Nov 2004 12:07


Return to dotConnect for PostgreSQL