PASSWORD RECOVERY

PASSWORD RECOVERY

Postby JORGEMAL » Mon 01 Dec 2008 23:32

I am using the Password Recovery control in ASP.NET to build a page for those users who have forgotten their password and the email I receive as a response includes the password but it seems to be coded or something because I get characters like "{a]_w=&" or "T^cV{yy" and, of course, this is not the password I am testing with. Is this a provider's issue or am I doing something wrong?

Please note that I am not writing any line of code; I am using the Password Recovery Control which is an automated process made by ASP.NET. I am only setting the control's properties.

Respectfully,
Jorge Maldonado
JORGEMAL
 
Posts: 164
Joined: Thu 03 Jul 2008 23:55

Postby Shalex » Thu 04 Dec 2008 13:56

When you use our ASP.NET Providers Model, you add this entry to your Web.config file:
Code: Select all

 
   
           type="Devart.Data.PostgreSql.Web.Providers.PgSqlMembershipProvider"
        description="dotConnect for PostreSQL membership provider"
        applicationName="/WebProviders"
        connectionStringName="ConnectionString"
        passwordFormat="Clear"
        enablePasswordRetrieval="true"
        minRequiredPasswordLength="1"
        requiresQuestionAndAnswer="true"
        minRequiredNonalphanumericCharacters="0"/>
 


Probably, you have set the passwordFormat attribute to "Hashed". Try using the "Clear" and "Encrypted" options. This issue was discussed here: http://www.devart.com/forums/viewtopic.php?p=41003

Please notify us about the results.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for PostgreSQL