Problem with datatime filed

Problem with datatime filed

Postby marlin » Mon 03 Nov 2008 15:32

Hi

I have problem with reading from datatime filed. For example, when I have table like this

CREATE TABLE test (
din timestamp
);

SELECT * FROM test always return year 2000-01-01 00:00. In my log file from postgres I get

2008-11-03 16:09:42 [27047] LOG: connection received: host=192.168.10.71 port=2949
2008-11-03 16:09:42 [27047] LOG: connection authorized: user=postgres database=velvet
2008-11-03 16:09:42 [27047] LOG: statement: SELECT version()
2008-11-03 16:09:42 [27047] LOG: statement: show integer_datetimes
2008-11-03 16:09:42 [27047] ERROR: unrecognized configuration parameter "integer_datetimes"
2008-11-03 16:09:42 [27047] LOG: statement: SET autocommit=true
2008-11-03 16:09:42 [27047] LOG: statement: SET datestyle=ISO

My Postgres version is

velvet=# SELECT version();
version
----------------------------------------------------------------------------------------------------------------
PostgreSQL 7.4.17 on i486-pc-linux-gnu, compiled by GCC cc (GCC) 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)
(1 row)


It look like commponenet discover wrong postgres version.

BTW.

I have commponenet for mobile devices I they work this same.

Best regards
marlin
marlin
 
Posts: 9
Joined: Mon 09 Jun 2008 14:15

Postby AndreyR » Tue 04 Nov 2008 08:06

Please specify your version of PostgreSQLDirect .NET.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby marlin » Tue 04 Nov 2008 08:31

VS 2008 SP 1 + Core Lab Proffesional 3.75.33
marlin
 
Posts: 9
Joined: Mon 09 Jun 2008 14:15

Postby AndreyR » Tue 04 Nov 2008 09:36

Could you please try to execute the query "show integer_datetimes" on your PostgreSQL server using your administration tool and provide us the error log, if any?
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby marlin » Tue 04 Nov 2008 10:14

velvet=# show integer_datetimes;
ERROR: unrecognized configuration parameter "integer_datetimes"
velvet=#
marlin
 
Posts: 9
Joined: Mon 09 Jun 2008 14:15

Postby AndreyR » Tue 04 Nov 2008 12:14

We are investigating the issue and will notify you about the results.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby AndreyR » Wed 05 Nov 2008 12:36

We have made a test build for you.
Please provide us with your e-mail (send a letter with your forum nick to the support * devart * com, for example).
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16


Return to dotConnect for PostgreSQL