Trial Version 3.75 breaks apps using version 2.20

Trial Version 3.75 breaks apps using version 2.20

Postby giedmer » Wed 15 Oct 2008 02:58

After installing trial version my existing apps are generating the following error:

Reference required to assembly 'CoreLab.Data, Version=4.70.24.0, Culture=neutral, PublicKeyToken=09af7300eec23701' containing the base class 'CoreLab.Common.DbCommandBase'. Add one to your project.

When I looked in the references in the class browser for CoreLab.Common namespace, DbCommandBase class does not exist, although using a reflector I can see that it does. Seems like the trial install created a dependence from version 2.20 PostgreSql namespace to version 4.70 Data namespace.

How do I fix this without uninstalling all CoreLab assemblies and re-installing the old version that I have? I would still like to try the trial version without commiting to upgrading... Thanks.
giedmer
 
Posts: 2
Joined: Wed 15 Oct 2008 02:49

Postby Shalex » Wed 15 Oct 2008 10:48

Please make sure your project contains reference to the CoreLab.Data assembly. Try setting the "Specific Version=false" property for the reference to CoreLab.Data. Does it help?
As I understand, you have unistalled PostgreSQLDirect .NET version 2.20 and installed the 3.75 version. Is it right?
Shalex
Devart Team
 
Posts: 7660
Joined: Thu 14 Aug 2008 12:44

Postby giedmer » Wed 15 Oct 2008 16:54

I have a license for version 2.20... which I use for production applications and I cannot uninstall it.

I installed the latest trial version with full install, which has assemblies with version 3.75 (for CoreLab.PostgreSql) and version 4.70 (for CoreLab.Data). I did not change any existing applications and I don't want to. I want to try the Trial new version for future projects. New and old assemblies should be able to run side-by-side, but it doesn't seem to be the case here.

Any ideas? Or should I just give up on Trial and stick with the old version until I'm ready to upgrade all existing application?
giedmer
 
Posts: 2
Joined: Wed 15 Oct 2008 02:49

Postby Shalex » Thu 16 Oct 2008 08:39

To be able to use several versions on one machine, we recommend you to follow these steps:
1. Install the 2.20 version of PostgreSQLDirect .NET. Copy CoreLab.Data.dll and CoreLab.PostgreSql.dll files from \Program Files\CoreLab\PostgreSqlDirect.NET2 to a temporary folder.
2. Uninstall this previous version.
3. Install newer (3.75) PostgreSQLDirect .NET version.
4. Delete from GAC the following files: policy.*.CoreLab.Data and policy.*.CoreLab.PostgreSql.
5. Add to GAC the *.dll files from the older (2.20) version.

Please note that there must be correct versions specified in your project's references.
Shalex
Devart Team
 
Posts: 7660
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for PostgreSQL