Deployment with ADO.net to entities support.

Deployment with ADO.net to entities support.

Postby andrewAtCognito » Fri 01 Aug 2008 10:42

We have been using postgreSQLDirect.net wtih the entity framework. We are looking to deploy this by including the installer for postgreSQLDirect and setting the install to "minimal" (as i read in the FAQ) but this then gives me an error:

Error: The store provider factory type 'CoreLab.PostgreSql.PgSqlDirectFactory' does not impliment the IServerProvider interface. Use a store provider that inplements this interface

If i install the full version from the installer the application works fine but the full install is not included in the licence.

Cheers,
Andrew
Cognito Software.
andrewAtCognito
 
Posts: 9
Joined: Fri 01 Aug 2008 10:27
Location: Crediton

Postby andrewAtCognito » Fri 01 Aug 2008 11:02

I had issues with verioning so the above issue is wrong.

I found that i can select custom and only tick select ADOEntites support and it works fine. Is this ok with the lience?
andrewAtCognito
 
Posts: 9
Joined: Fri 01 Aug 2008 10:27
Location: Crediton

Postby AndreyR » Fri 01 Aug 2008 13:31

Could you please specify more details on the situation?
You cannot redistribute the installer of PostgreSqlDirect .NET.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby andrewAtCognito » Mon 04 Aug 2008 09:43

AndreyR wrote:Could you please specify more details on the situation?
You cannot redistribute the installer of PostgreSqlDirect .NET.


i read this in the FAQ as a possilbe way of installing the correct files:

Another way to install the *.dll files needed is to launch setup program of PostgreSQLDirect .NET and choose "compact" option. Note that according to License Agreement this is the only setup mode that you can use on target machine.



I believe the problem i have is that when using the ADO.net to entities visual studio doesn't include the correct dll in the referance list stopping me from selecting them in the installer. If you could give me the names of the DLL's i need to put in the GAC it may slove the problem.

Hopfully this is a little clearer.
andrewAtCognito
 
Posts: 9
Joined: Fri 01 Aug 2008 10:27
Location: Crediton

Postby AndreyR » Mon 04 Aug 2008 15:12

Assemblies you need to put in GAC for ADOEntities support are CoreLab.Data.dll, CoreLab.PostgreSql.dll and CoreLab.PostgreSql.Entity.dll.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby andrewAtCognito » Mon 11 Aug 2008 11:42

AndreyR wrote:Assemblies you need to put in GAC for ADOEntities support are CoreLab.Data.dll, CoreLab.PostgreSql.dll and CoreLab.PostgreSql.Entity.dll.


Thanks for advice.

I have added these assembiles into the GAC but iam getting an error of:

"Unable to find the requested .Net Framework Data Provider. It may not be installed"


Cheers,
Andrew Twitchett
Cognito Software.
andrewAtCognito
 
Posts: 9
Joined: Fri 01 Aug 2008 10:27
Location: Crediton

Postby AndreyR » Tue 12 Aug 2008 12:21

Try adding the following line to the DbProviderFactories section of the local app.config or machine.config file (%WinDir%\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config):
Code: Select all
 
...
     
...
         
...
     

...
 

AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby andrewAtCognito » Wed 13 Aug 2008 09:20

thanks that worked.

Cheers,
Andrew Twitchett
andrewAtCognito
 
Posts: 9
Joined: Fri 01 Aug 2008 10:27
Location: Crediton


Return to dotConnect for PostgreSQL