License problem after uninstall

License problem after uninstall

Postby AlexanderPriem » Mon 18 Feb 2008 15:17

Hello,

I have re-installed Windows (etc.) on my development PC, and now I am running into weird problems with PostgreSQLDirect.NET licensing.

I have installed Windows XP, then all the latest Windows updates, then CodeGear RAD Studio 2007 (also with all the updates from CodeGear). Then I installed CoreLab PostgreSQLDirect.NET 3.30 (.NET 2.0 version, Standard Site License).

Every project I build gives me the following error (which I cannot find anywhere an your website or in forums) :

Assembly (C_SOL) is not licensed to use PostgreSQLDirect .NET.
Please correct license information.

That is the server error I receive.

I have uninstalled PostgreSQLDirect.Net, removed all Corelab Files (corelab.*) and reinstalled, but that did not help.

I have added the licenses.licx to the project.

This is very weird. Everything ran OK before I reinstalled Windows, but now I cannot get it running.

Can you tell me why this message is being shown? And what I can do to solve it? I cannot find this error message on your website.

We have a Standard Site license for 3.30.

Thanks in advance, Alexander.
AlexanderPriem
 
Posts: 29
Joined: Fri 24 Feb 2006 09:54

Postby AlexanderPriem » Mon 18 Feb 2008 15:31

I have found out that the apllication DOES work correctly on my development machine when I REMOVE the licences.licx file from the project. The web-app (which is ASP.NET 2.0) does work correctly in that case.

However, I remember that if I dont include the licences.lics file into the project, I cannot deploy it to another server, I get a license error in that case.

Before I re-installed Windows, I had the licences.licx file in my project, and it worked fine, both on my development PC as on another (production) server.

I hope you can clarify this for me.

The contents of my licences.lics file is as follows :

CoreLab.PostgreSql.PgSqlConnection, CoreLab.PostgreSql
AlexanderPriem
 
Posts: 29
Joined: Fri 24 Feb 2006 09:54

Postby AlexanderPriem » Mon 18 Feb 2008 15:36

P.S. I dont know if this information helps, but I do NOT use visual components, I create the PgsqlConnection at runtime (in code).

This has never been a problem.

I hope to hear from you soon :)
AlexanderPriem
 
Posts: 29
Joined: Fri 24 Feb 2006 09:54

Postby Alexey.mdr » Mon 18 Feb 2008 17:46

Try copy/paste this line into license.licx file:
Code: Select all
CoreLab.PostgreSql.PgSqlConnection, CoreLab.PostgreSql, Version=3.30.23.0, Culture=neutral, PublicKeyToken=09af7300eec23701

then recompile your project.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby AlexanderPriem » Mon 18 Feb 2008 19:35

I tried your suggestion, but I get the same error message :

[PgSqlException (0x80004005): Assembly (C_SOL) is not licensed to use PostgreSQLDirect .NET.
Please correct license information.]

This error (exception) is thrown when I call the Open() method of the PgSqlConnection. The exact same code compiled and worked perfectly before I reinstalled the PC.

The only difference is that before the reinstallation I used the Rad Studio 2007 Architect Trial, and now I am using a registered Rad Studio 2007 Architect with the latest updates from CodeGear.
AlexanderPriem
 
Posts: 29
Joined: Fri 24 Feb 2006 09:54

Postby AlexanderPriem » Mon 18 Feb 2008 23:33

I have tried several times to get it working on my development pc, but no luck. Without the licenses.licx it works, but as soon as I add the licenses.licx file, it wont work on my development machine.

Could this be some incompatibility with the registered Rad Studio 2007, or the november 2007 update? I had no problems with the Rad Studio 2007 Trial.

By the way, I dont know if this is relevant, but I dont get a file named "App_Licenses.dll" in my bin folder. I get the files x.dll, x.dll.config, x.dll.licenses in my bin folder (x being the name of my app).

Maybe this information helpps you further. I hope this cant be solved soon, as this prevents me from developing my web app :(
AlexanderPriem
 
Posts: 29
Joined: Fri 24 Feb 2006 09:54

Postby Alexey.mdr » Tue 19 Feb 2008 13:08

We couldn't reproduce this error on RAD Studio 2007 Version 11.0.2799.9201 and Standard
PostgreSQLDirect .NET 3.30 for .NET 2.0
Could you please make a sample project with only one connection and send us a compiled binary?
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby AlexanderPriem » Tue 19 Feb 2008 13:15

Hmm, there have been at least two updates after version 11.0.2799.9201. Maybe this is the cause of it. I am using the latest version, which is 11.0.2902.10471.

I will create a test-app and send you the code and binary...
AlexanderPriem
 
Posts: 29
Joined: Fri 24 Feb 2006 09:54

Postby Alexey.mdr » Tue 19 Feb 2008 15:31

Ok. We are waiting for a test project.
We will try to find out what causes
the license problem as soon as possible.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby AlexanderPriem » Tue 19 Feb 2008 15:43

I sent the test project to info@crlab.com two hours ago.

Did you receive it ?
AlexanderPriem
 
Posts: 29
Joined: Fri 24 Feb 2006 09:54

Postby Alexey.mdr » Wed 20 Feb 2008 12:55

Yes, we did.
We are investigating this problem.
I will send you an email as soon as possible.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24


Return to dotConnect for PostgreSQL