using Microsoft components

using Microsoft components

Postby CNPSV » Mon 07 Jan 2008 13:42

Hello. I have a question about using the built in components of Visual Studio. I am using PostgreSQLDirect .net only for the connection with the database, and Visual Studio 2008. When I try to drag a Microsoft component on a form, I get the following error: "Code generation for property 'Connection' failed. Error was: 'Component CoreLab.PostgreSql.PgSqlConnection does not have Site"
CNPSV
 
Posts: 27
Joined: Thu 01 Nov 2007 09:48

Postby Alexey.mdr » Tue 08 Jan 2008 13:25

Could you please send us a small project that reproduces the error?
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

project sources

Postby anca » Wed 09 Jan 2008 07:39

hy, i made a new project reproducing the errors. first, at the end of the dataset creation it says that it can't create relations, the when i try to drag someting on the form it gives me the error with the site problem. anyone knows what is this??

Image

Image

here are the project sources made in VS 2008 with the database backup in postgresql. if you could look at it and tell me what is all about, i would appreciate, thanks.

http://stud.usv.ro/~opascariu/project_problems.rar
anca
 
Posts: 3
Joined: Tue 08 Jan 2008 10:57

Postby Alexey.mdr » Wed 09 Jan 2008 12:28

These bugs are currently being fixed.
We will issue the next build as soon as possible
Try to use Tools -> PostgreSQL -> DataSet Wizard...
instead of standard Data-> Add New Data Source.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24


Return to dotConnect for PostgreSQL