Firebird versions supported

Firebird versions supported

Postby CCostelloe » Fri 02 Jan 2009 00:00

I am trying the latest driver dbexpida40.dll filedate 20/11/2008 with Codegear RAD Studio 2007, CBuilder personality, and trying to connect to a Firebird 1.0X database which exists (I can open it with FlameRobin and Delphi 7 applications with their Interbase driver), but I get the error below. Does your driver really support all Firebird versions, as stated on your product page, or am I doing something wrong?

Ciaran Costelloe

---------------------------
Debugger Exception Notification
---------------------------
Project InvRetNightrun_BDS.exe raised exception class TDBXError with message 'unavailable database'.
CCostelloe
 
Posts: 5
Joined: Thu 07 Aug 2008 08:59

Postby CCostelloe » Sun 04 Jan 2009 01:07

I still have a problem, but the last error was due to a mistake in the way I was specifying the server. After fixing it, however, I get the error below.

From WireShark, it appears your driver is trying to connect with preferred version 0 (but minimum type 65536) and very high other preferred versions (131072, 196608, etc), whereas FlameRobin tries version 8 and 10, with my Firebird server accepting using version 10, which is presumably why my Firebird version is not supported.

---------------------------
Debugger Exception Notification
---------------------------
Project InvRetNightrun_BDS.exe raised exception class TDBXError with message 'connection rejected by remote interface'.
CCostelloe
 
Posts: 5
Joined: Thu 07 Aug 2008 08:59

Postby Plash » Tue 06 Jan 2009 08:04

Devart dbExpress driver uses InterBase/Firebird client library to work with a server. This error can occur if you have gds32.dll of a wrong version. Check that your gds32.dll is from Firebird. To use fbclient.dll instead set the VendorLib property of TSQLConnection to 'fbclient.dll'.
Plash
Devart Team
 
Posts: 2844
Joined: Wed 10 May 2006 07:09

Postby CCostelloe » Wed 07 Jan 2009 23:59

Thank you very much, I will check that out carefully because I am not sure exactly which I have.
CCostelloe
 
Posts: 5
Joined: Thu 07 Aug 2008 08:59

Postby CCostelloe » Thu 08 Jan 2009 01:02

Thanks very much, you have made me very happy, I can finally start porting my apps to Codegear. I used an fbclient.dll dated 12/12/2007 (I don't remember where I got it) with Codegear 2007 and could connect to a Firebird 1.0x server.
CCostelloe
 
Posts: 5
Joined: Thu 07 Aug 2008 08:59


Return to dbExpress driver for InterBase & Firebird