ORA-12504: TNS: listener was not given the SERVICE_NAME in CONNECT_DATA

ORA-12504: TNS: listener was not given the SERVICE_NAME in CONNECT_DATA

Postby apmcmillan3 » Mon 27 Oct 2014 15:59

When trying to add a connection to my oracle database I get the messagebox error saying "ORA-12504: TNS:listener was not given the SERVICE_NAME in CONNECT_DATA".

What is weird is that it I had the trial versions of dotConnect and dbForge installed, and they were working great. So I purchased them, uninstalled the trial, installed the registered versions, and now it won't work. When I try to use dbForge Studio Express, it does not allow you to specify the SID or SERVICE_NAME. but when I try to connect via dbForge Fusion in Visual Studio 2013, I can click on the "Advanced..." button and specify the SERVICE NAME in the list of properties...but it still gives me the same error.

What can I do to get this fixed?
apmcmillan3
 
Posts: 6
Joined: Tue 21 Oct 2014 13:07

Re: ORA-12504: TNS: listener was not given the SERVICE_NAME in CONNECT_DATA

Postby alexa » Mon 27 Oct 2014 17:15

Please note that the Express edition of dbForge doesn't include Direct mode allowing to connect with no Oracle client being installed in the system.

In case you would like to use an Oracle client to connect to the Oracle server, we recommend you to refer to the following article explaining how to correctly configure your Oracle Instant Client so our tools can work with it http://blogs.devart.com/dbforge/how-to-configure-oracle-instant-client.html
alexa
Devart Team
 
Posts: 2170
Joined: Fri 24 Jun 2011 14:17


Return to dbForge for Oracle