Customized formatting

Customized formatting

Postby Valgardur » Wed 20 Nov 2013 14:23

I am trying to use the SQL Formatter... without much success.

First of all, it would be great to be able to simply format open file, rather than going through the dialog and select files. (And no, I do not want to use the format-on-paste).

More importantly, when I try to customize the formatting, any changes I make are ignored.

There are two files in FormatProfiles directory, "Default.xml" and "Quest Software Toad.xml". Both have new date attribute when I edit and save the options.

Sometimes "Default" shows up in Tools/Options/Text Editor/Formatting / Profiles. Sometimes only "Quest..". Sometimes both. And sometimes 3, 4, 5 or 6 instances of "Quest...".

No matter what I do, I alway the the same formatting, your "factory" settings..
Valgardur
 
Posts: 164
Joined: Tue 24 Nov 2009 19:33

Re: Customized formatting

Postby alexa » Wed 20 Nov 2013 15:36

First of all, it would be great to be able to simply format open file, rather than going through the dialog and select files. (And no, I do not want to use the format-on-paste).
Please note that there is the 'Format Document (Ctrl+K, D)' command available in the main menu 'Edit -> Advanced'.

More importantly, when I try to customize the formatting, any changes I make are ignored.

No matter what I do, I alway the the same formatting, your "factory" settings..
Please make sure you edit the profile that is active.

Also, please make sure that, after you close the 'Edit Profile' dialog by clicking the 'OK' button in the dialog, you also click 'OK' in the 'Options' window.

There are two files in FormatProfiles directory, "Default.xml" and "Quest Software Toad.xml". Both have new date attribute when I edit and save the options.

Sometimes "Default" shows up in Tools/Options/Text Editor/Formatting / Profiles. Sometimes only "Quest..". Sometimes both. And sometimes 3, 4, 5 or 6 instances of "Quest...".
We were able to reproduce this issue and will fix it in one of the next builds of the product. We will notify you once it's available for downloading.
alexa
Devart Team
 
Posts: 2175
Joined: Fri 24 Jun 2011 14:17

Re: Customized formatting

Postby Valgardur » Wed 20 Nov 2013 15:55

Thanks for a quick reply, yes CTRL-K + D is fine, but not that obvious.

The edit profile is active, but they appear randomly and sometimes the same is repeated up to six times.

Looking forward to an update, but is there any way for me to modify the formatting in the current version?
Valgardur
 
Posts: 164
Joined: Tue 24 Nov 2009 19:33

Re: Customized formatting

Postby alexa » Wed 20 Nov 2013 16:10

Thank you for the reply.

In the meanwhile please try editing only the Default profile.
alexa
Devart Team
 
Posts: 2175
Joined: Fri 24 Jun 2011 14:17

Re: Customized formatting

Postby Valgardur » Thu 21 Nov 2013 11:30

I have not been very clear.. I was trying to edit the Default profile (as well as the other) - it has no effect, all code is formatted like specified by you "factory settings".
Valgardur
 
Posts: 164
Joined: Tue 24 Nov 2009 19:33

Re: Customized formatting

Postby alexa » Thu 21 Nov 2013 13:25

Could you please also confirm that this happens despite the fact:
Also, please make sure that, after you close the 'Edit Profile' dialog by clicking the 'OK' button in the dialog, you also click 'OK' in the 'Options' window.


Then, please also try to run dbForge with the 'Run as administrator' command of Windows Explorer and let us know if it helps.
alexa
Devart Team
 
Posts: 2175
Joined: Fri 24 Jun 2011 14:17

Re: Customized formatting

Postby Valgardur » Thu 21 Nov 2013 14:39

I did click OK and OK, and the file date is modified.

Also, if I reopen the default profile my settings are there, for example all lowercase options.

However, the formatter ignores this, both SQL formatter and CTRL_K + D.

I have administrator rights.

Run as administrator makes no difference.
Valgardur
 
Posts: 164
Joined: Tue 24 Nov 2009 19:33

Re: Customized formatting

Postby alexa » Thu 21 Nov 2013 16:28

Could you please provide us the following:

1. The Default.xml profile file with the changes you made.
2. Describe what changes you made in the profile.
3. The full SQL script to reproduce the issue.

You can send a reply straight to our support system at supportATdevartDOTcom, so we will keep further correspondence with you on this issue via that system.
alexa
Devart Team
 
Posts: 2175
Joined: Fri 24 Jun 2011 14:17

Re: Customized formatting

Postby Valgardur » Tue 03 Dec 2013 12:26

Anything on this? I sent files on November 21st
Valgardur
 
Posts: 164
Joined: Tue 24 Nov 2009 19:33

Re: Customized formatting

Postby alexa » Tue 03 Dec 2013 14:44

Unfortunately, we haven't received it.

Could you please send it once again?
alexa
Devart Team
 
Posts: 2175
Joined: Fri 24 Jun 2011 14:17

Re: Customized formatting

Postby Valgardur » Tue 03 Dec 2013 14:47

I have.. this is the content of the message:

Attached is the default file mentioned in http://forums.devart.com/viewtopic.php?f=22&t=28362 I have tried some changes, but only trying to get keywords, variables and identifiers in lower case.

I cannot send any of my working files, but I attached a simple file that I would expect to be formatted so keywords are lowercase.

By the way, the CTRL-K, D command is not available and the key combination does nothing.
Valgardur
 
Posts: 164
Joined: Tue 24 Nov 2009 19:33

Re: Customized formatting

Postby alexa » Wed 04 Dec 2013 11:55

Unfortunately, we still haven't received the e-mail.

Could you please try to send it to alexaATdevartDOTcom ?
alexa
Devart Team
 
Posts: 2175
Joined: Fri 24 Jun 2011 14:17

Re: Customized formatting

Postby Valgardur » Wed 04 Dec 2013 12:34

Just sent...
Valgardur
 
Posts: 164
Joined: Tue 24 Nov 2009 19:33

Re: Customized formatting

Postby alexa » Wed 04 Dec 2013 13:25

Thank you for the reply. We confirm receiving the e-mail. Replied to you with new instructions.
alexa
Devart Team
 
Posts: 2175
Joined: Fri 24 Jun 2011 14:17

Re: Customized formatting

Postby alexa » Tue 04 Mar 2014 17:29

We would like to let you know that we have released the new build 3.5.322 of dbForge Studio for Oracle where the issue you reported is fixed http://www.devart.com/dbforge/oracle/studio/download.html

Thank you for your help in improving dbForge Studio for Oracle.
alexa
Devart Team
 
Posts: 2175
Joined: Fri 24 Jun 2011 14:17

Next

Return to dbForge for Oracle