Schema Comparer Suddenly started crashing

Schema Comparer Suddenly started crashing

Postby Stuporman » Fri 19 Aug 2011 20:17

Hello,

I downloaded a trial edition of dbForge Schema Comparer for Oracle. I tried a compare and synchronize operation, and it worked just fine. However, when I try to repeat the operation, it is now crashing. It almost seems like maybe Windows is deciding it has crashed before giving it the opportunity to finish its operation because it registered as not responding briefly for the initial successful attempt. I'd love to use this product if I can make it work.

Specs:
Windows 7 Ultimate x64
Intel Core 2 Duo T9400
4 GB RAM

One of the databases involved is Oracle 11g Personal Edition installed on the same computer as dbForge Schema Comparer. The other is our development server. I'm still able to access both databases in SQL Developer using the same Oracle Client. Any help would be appreciated.

EDIT: I've narrowed down the issue to the connection with my development database. I'll try to figure out what's wrong with it. Some error handling will make the next release better.
Stuporman
 
Posts: 1
Joined: Fri 19 Aug 2011 20:08

Postby PavelSh » Mon 22 Aug 2011 13:52

Hello,

Thank you for your post.

It looks like a problem with Oracle client x64. (http://www.devart.com/forums/viewtopic.php?t=21384). If you send us your error report, we would be able to get more details on the error.

As a possible solution, please try to use direct connection mode. You can configure it in the connection properties dialog. You can also create a new connection with direct mode settings.

P.S. The problem with x64 client will be resolved as soon as possible.
PavelSh
 
Posts: 1
Joined: Mon 22 Aug 2011 11:14


Return to dbForge for Oracle