OraDev freezes on schema export

OraDev freezes on schema export

Postby bigkahuna » Tue 10 Jun 2008 00:33

Hi

I am trying out the developer studio product. Whenever I try to extract the schema (my database is 10.g) oradev freezes and I have to terminate the process with windows task manager.

Any idea?

thanks
bigkahuna
 
Posts: 5
Joined: Tue 10 Jun 2008 00:29

Postby Alexz » Tue 10 Jun 2008 10:14

Please, provide us the following information:
  1. Specify connection string that you use.
  2. What exact version of OraDeveloper Studio do you use? You can find it in the Help-> About dialog.
  3. What do you mean by 'Extract schema'? Do you use 'Export Utility' or 'Schema Export'?
  4. Specify exact versions of your Oracle Server and client.
Alexz
Devart Team
 
Posts: 165
Joined: Wed 10 Aug 2005 08:30

Postby bigkahuna » Tue 10 Jun 2008 15:45

I am using the following

ClientOS: Windows XP SP2
Database: Oracle 10g
OraDev: 2.55.121
Function: Schema export (structure only, any option)
Connection string (from connection properties in o/d, the connection uses TNS): Server=US1;User Id=SENJUL12;
Database version: Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bit
Client: 10.2

My schema has 151 tables. when i try both schema export and generate DDL commands - the app freezes and i have to terminate the process. the target files shows zero byte length thru the process, cpu is low, the output pane in o/d shows some info (object counts) but nothing else.

One more note - when looking at the help the following is showing up:

Core Lab OraDeveloper Studio
What's New in OraDeveloper Studio 1.50


When i try to perform the same operation for individual objects there is no problem however that does not work for me.

Thanks
bigkahuna
 
Posts: 5
Joined: Tue 10 Jun 2008 00:29

Postby bigkahuna » Wed 11 Jun 2008 22:46

One more - seems that when single objects are exported (either thru export or generate DDL) the feature works. however when executing on large schema, it does not.

thanks

Gadi
bigkahuna
 
Posts: 5
Joined: Tue 10 Jun 2008 00:29

Postby Alexz » Fri 13 Jun 2008 12:05

Unfortunately, we cannot reproduce the problem.
Are you using a connection to a remote server?
If you can see the information about process (objects count) in the output window, the Schema Export is working.
Alexz
Devart Team
 
Posts: 165
Joined: Wed 10 Aug 2005 08:30

Postby bigkahuna » Fri 13 Jun 2008 15:02

Well, for me it is not. i indeed can see the counters, but the progress dialog never closes, and eventually, windows add the "(not responding)" text to the window title, forcing me to kill the process. so from my perspective, this is not working and no output file is generated.

I am indeed using remote databases (3 distinct different systems) and this is the only operation that freezes.

as for cpu usage - at that freeze point the cpu is very low and not used by oradev.exe.

thanks
bigkahuna
 
Posts: 5
Joined: Tue 10 Jun 2008 00:29

Postby Alexz » Tue 17 Jun 2008 07:10

bigkahuna wrote:I am indeed using remote databases (3 distinct different systems) and this is the only operation that freezes.
Could you please create a test account for us on your remote server?
Alexz
Devart Team
 
Posts: 165
Joined: Wed 10 Aug 2005 08:30

Postby bigkahuna » Tue 17 Jun 2008 14:49

These are inside the corp network and cannot be accessed remotely/externally.

What info can i get that will help?
bigkahuna
 
Posts: 5
Joined: Tue 10 Jun 2008 00:29

Postby Alexz » Wed 18 Jun 2008 06:34

We want to try to simulate your schema on our computer. Could you please send us content of sys.user_objects and sys.user_tables by mail?
Alexz
Devart Team
 
Posts: 165
Joined: Wed 10 Aug 2005 08:30


Return to dbForge for Oracle