Unable to Build License in Project using VWD 2005

Unable to Build License in Project using VWD 2005

Postby Cody21 » Sat 03 Mar 2007 16:47

This customer's POST spells out my issue: http://crlab.com/forums/viewtopic.php?t ... ce+license

However, I can NOT see a Context Menu item to "Build Runtime Licenses" when I right-click on the "licenses.licx" file that I created (and inserted the 2 Corelab statements you outlined). I created this file in the /bin difrectory of my project. I'm assuming that's where it is to be placed. I even shut down and restarted VWD. Still no context menu to Build my license. Is there another way to do this? (e.g., command line? If so, what is the command I enter?)

I am absolutely stumped on this and cannot get my published site to work in accessing the data. (the ugly License not Found problem.) I will continue to search your forum for an answer, but as of yet, nada. I need some assistance ASAP. Thank you.
Cody21
 
Posts: 112
Joined: Thu 01 Mar 2007 00:58

Postby Cody21 » Sat 03 Mar 2007 16:52

PS - here's the version info:

VWD 2005
8.0.50727.762 (SP.050727-7600)

MS .NET Framework 2.0.50727
Cody21
 
Posts: 112
Joined: Thu 01 Mar 2007 00:58

Postby Cody21 » Sat 03 Mar 2007 17:44

One more update after another hour of trying to solve this.

I found a link in your forum to "manually" compile the MyApplication.exe.licenses file. After trial and error, I succeeded in generating the file. I copied the file to my /bin directory and re-published my site... Same exact error (license not found). I now have a licenses.licx and a myapplication.exe.licenses in my /bin directory.

Like the other customer, you refer to "embedding" the file ... I have no clue what this is as I see no such option in VWD 2005.


Help please.... and of course, thanks for being there for me.
Cody21
 
Posts: 112
Joined: Thu 01 Mar 2007 00:58

Postby Alexey » Tue 06 Mar 2007 07:20

As answered in the post you mentioned we had followed the documentation and have had no problems creating App_Licenses.dll assembly. Our VWD version is 8.0.50727.42 (RTM.050727-4200).
I suggest you reinstalling MySQLDirect .NET. Make sure that MySQLDirect .NET isn't installed and there are no CoreLab.MySql.dll, CoreLab.MySql.Addin.dll, CoreLab.MySql.Design.dll in the GAC before installation.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for MySQL