'License not found' - Licensing ASP.NET 2.0 apps with Visual Web Developer

'License not found' - Licensing ASP.NET 2.0 apps with Visual Web Developer

Postby LVdB » Tue 30 Jan 2007 17:29

Hi,

I am trying to deploy a web application that uses MySQLDirect.NET. As an IDE I use Visual Web Developer. When I copy my source aspx files to the server, I get the dreaded 'License not found' exception.

According to the documentation, these are my options:

Licensing ASP.NET Applications
In deployment of ASP.NET application to server you have two alternative ways.

First, you can compile the application entirely, so that web server does not perform any compilation on demand. In this case licensing web applications is same as licensing common WinForms application.
The other way is to upload source files to server, where they are compiled on user request. In this case you have to have special assembly App_Licenses.dll in the Bin directory of your site. To create this assembly execute Build Runtime Licenses command in the licenses.licx file context menu in the Solution Explorer view. Required assembly will be created automatically.


However, I cannot use either of these options. Visual Web Developer does not allow you to create the assemblies for the first option, and the context menu does not contain the 'Build Runtime Licenses' command.

So what can I do?

Thanks,

Luc
LVdB
 
Posts: 17
Joined: Mon 11 Sep 2006 12:53

Postby Serious » Wed 31 Jan 2007 07:11

We followed the documentation and had no problems creating App_Licenses.dll assembly.

We created and added to the project file "licenses.licx" with following content: "CoreLab.MySql.MySqlConnection, CoreLab.MySql". Then we executed "Build Runtime Licenses" command in this project item context menu. Required assembly "App_Licenses.dll" was correctly created.

We used VWD 2005 Express Edition 8.0.50727.42 (RTM.050727-4200). If you still experience problems with licensing please provide information about your environment (VWD version, etc.).
Serious
 

Postby LVdB » Wed 31 Jan 2007 08:03

It was a problem with VWD. I used version 8.0.50727.762. After reading your message I tried again, and it worked. It looks like VWD needed a restart before it produced the right context menu for the licenses file.

Thanks for your help, much appreciated.

Luc
LVdB
 
Posts: 17
Joined: Mon 11 Sep 2006 12:53

Postby Alexey » Wed 31 Jan 2007 08:16

You are welcome.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for MySQL