Trouble using .NET membership in console application

Trouble using .NET membership in console application

Postby mr breaker » Wed 25 Oct 2006 19:26

Hi,

I am having some trouble with a .NET 2.0 console application. I don't think it's an issue with the driver...just the way I am configuring it. If anyone has run into this, I'd appreciate any feedback.


When I try to access the Membership class I get this exception:

"Could not load type 'CoreLab.MySql.Web.Providers.MySqlMembershipProvider' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. (C:\Documents and Settings\kramerd\My Documents\Visual Studio 2005\Projects\Portal\BotFilteringConsoleApplication\bin\Debug\BotFiltering.vshost.exe.config line 12"

I have added the CoreLab.MySql.dll and CoreLab.MySql.Web.dll as references to my project. I am also using the same .config settings as an ASP.NET application located in the same solution where the Membership methods work ok.

This is the app.config file I am using:




























Thanks!
mr breaker
 
Posts: 20
Joined: Thu 31 Aug 2006 18:19

Postby Alexey » Thu 26 Oct 2006 06:14

Please send us small test project to reproduce the problem. Use e-mail address provided in the Readme file. Do not use third party components.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby mr breaker » Thu 26 Oct 2006 16:09

Sent, thanks.
mr breaker
 
Posts: 20
Joined: Thu 31 Aug 2006 18:19

Postby Alexey » Fri 27 Oct 2006 06:26

As i remember, you had some problems with our public e-mail address (it doesn't like hotmail). So please send it to me directly (you should know my address).
Sorry for not telling this before.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for MySQL