ASP.NET Identity 2 Login Error

ASP.NET Identity 2 Login Error

Postby dangerdarren » Fri 04 Nov 2016 09:35

Hi - I really hope someone can help me out...

I am trying to use ASP.NET Identity 2, with EntityFramework using MySQL dotConnect...getting some really weird behavior. I went though the setup just as Devart's instructions say. I am able to register a user no problem, however, when use the SignInManager to log a user in, it throws a concurrency exception at me. When a user enters the wrong password, behavior is as expected, but when they enter the correct password, I get the following exception.

Store update, insert, or delete statement affected an unexpected number of rows (0)


Line that causes the problem:

Code: Select all
    var result = await SignInManager.PasswordSignInAsync(strEmail, strPassword, bRememberMe, shouldLockout: true);


Hopefully someone can help!
dangerdarren
 
Posts: 1
Joined: Fri 04 Nov 2016 09:27

Re: ASP.NET Identity 2 Login Error

Postby Pinturiccio » Wed 09 Nov 2016 11:42

We could not reproduce the issue. Please create and send us a test project which reproduces the issue.

You can archive your project and upload it to our ftp server (ftp://ftp.devart.com/, credentials: anonymous/anonymous ) or to any file exchange server so that we could download it from there. You can send us the password to the archive via our contact form.
Pinturiccio
Devart Team
 
Posts: 2044
Joined: Wed 02 Nov 2011 09:44

Re: ASP.NET Identity 2 Login Error

Postby kstough93 » Sat 18 Mar 2017 23:55

I am having this same problem, only with an addtorole call:

var result1 = UserManager.AddToRole(user.Id, "Admin");

I am using MySQL 5.7.17 and the latest dotConnect driver 8.8.862.

The user create call:

var chkUser = UserManager.Create(user, userPWD);

succeeds, but then fails on the AddToRole. I have this issue currently with two different applications. Any guidance would be greatly appreciated.
kstough93
 
Posts: 4
Joined: Sat 16 Jul 2016 02:22

Re: ASP.NET Identity 2 Login Error

Postby Shalex » Tue 21 Mar 2017 16:04

Please try using the "Found Rows=true;" connection string option. Refer to http://forums.devart.com/viewtopic.php?t=28529#p97236.

Does this help?
Shalex
Devart Team
 
Posts: 7824
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for MySQL