License not found in setup project

License not found in setup project

Postby BSV » Tue 26 Nov 2013 13:43

I've created a windows forms application.
When I run it, it works fine.
When I install it on another computer I get the following error (on probably my licenses.licx file):

License not found. Please view "Licensing" topic in dotConnect for MySQL documentation for details or contact Devart technical support.

I use Visual studio 2008 and Devart.Data.Mysql.dll version 5.50.54.0

I already tried to remove the compiled license from the solution and do a 'clean and rebuild'.
I also tried to manually compile the licensefile.

But nothing helps. How can I include the license file in my setup project? Thanks in advance.
BSV
 
Posts: 1
Joined: Tue 26 Nov 2013 12:43

Re: License not found in setup project

Postby Pinturiccio » Thu 28 Nov 2013 15:36

BSV wrote:I already tried to remove the compiled license from the solution and do a 'clean and rebuild'.
I also tried to manually compile the licensefile.

Please describe the steps you have performed in details.

BSV wrote:License not found.

This exception means that the license resource was not added to your application.
When you create an application that uses Devart assemblies, it must have a license resource. License information is a specially formed embedded resource. It is checked when a connection is opened.
dotConnect for MySQL includes License Wizard that helps you configure license information. To invoke the wizard choose MySQL | License Information from the Visual Studio Tools menu. Then click the Fix button in the dialog and follow the wizard's instructions. After the wizard finishes its work, rebuild your application.
For more information, please refer to http://www.devart.com/dotconnect/mysql/docs/?Licensing.html

You can add the license manually.
Perform the following:
1. Create the licenses.licx file;
2. Open the file with a text editor and add the following line to it: Devart.Data.MySql.MySqlConnection, Devart.Data.MySql;
3. Save the file and add it to your project;

if the issue is still reproduced, please reinstall dotConnect for MySQL:
1. Uninstall dotConnect for MySQL;
2. Remove all Devart.* and policy.*.Devart.* files from the GAC;
3. Clear the Program Files\Devart\dotConnect and Program Files\Common Files\Devart\dotConnect folders;
4. Install dotConnect for MySQL;
5. Remove the licenses.licx file from your project;
6. Add the license resource to your project;
7. Delete all files from the bin and obj folders and rebuild the project.

Please also create a simple test project and add a license resource to it. Build the project and send the result file to us.
Pinturiccio
Devart Team
 
Posts: 2020
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for MySQL