dbMonitor issue in Pro version (in Mono)

dbMonitor issue in Pro version (in Mono)

Postby tleslie » Fri 31 Aug 2012 19:17

I successfully deployed my project to Mono/Linux env.
At the time i used the dll of Devart.Data.Mysql of the free version.

Then i wanted to do some dbMonitor stuff, and I paid for the Pro version.
I changed the dll in my VS2010 project, and dbMonitor works fine.
If i know deploy on Mono/Linux and even take out the dbMonitor ref
in my start up method, i still get in Mono any time i access dotConnet:


System.EntryPointNotFoundException: QueryPerformanceFrequency
at (wrapper managed-to-native) Devart.Common.a0:QueryPerformanceFrequency (long&)
at Devart.Common.a0.b () [0x00000] in <filename unknown>:0
at Devart.Common.a0..cctor () [0x00000] in <filename unknown>:0


if i change the mono Devart.Data.Mysql dll back to the free one,
its ok, accept I get a

Could not load type 'Devart.Data.MySql.MySqlMonitor' from assembly 'Devart.Data.MySql, Version=7.1.58.0, Culture=neutral, PublicKeyToken=09af7300eec23701'.

Description: HTTP 500. Error processing request.

Stack Trace:

System.TypeLoadException: Could not load type 'Devart.Data.MySql.MySqlMonitor' from assembly 'Devart.Data.MySql, Version=7.1.58.0, Culture=neutral, PublicKeyToken=09af7300eec23701'.
at System.Web.SessionState.SessionStateModule.OnSessionStart () [0x00000] in <filename unknown>:0
at System.Web.SessionState.SessionStateModule.OnAcquireRequestState (System.Object o, System.EventArgs args) [0x00000] in <filename unknown>:0
at System.Web.HttpApplication+<RunHooks>c__Iterator5.MoveNext () [0x00000] in <filename unknown>:0
at System.Web.HttpApplication+<Pipeline>c__Iterator6.MoveNext () [0x00000] in <filename unknown>:0
at System.Web.HttpApplication.Tick () [0x00000] in <filename unknown>:0

the first time for a session access, but after this error, it then works
fine.

So in order to have it work on mono, i would have to
have my VS2010 have the free Devart dll, and deploy to mono,
but then when i want to use dbMonitor??????
as well, if i am restricted to the free, if i exceed 10 entities?
it will stop working even when i use above work around?
It would be nice go get the licensed Devart.Data.Mysql.dll working
on the mono , yet not have it drop the

System.EntryPointNotFoundException: QueryPerformanceFrequency
at (wrapper managed-to-native) Devart.Common.a0:QueryPerformanceFrequency (long&)
at Devart.Common.a0.b () [0x00000] in <filename unknown>:0
at Devart.Common.a0..cctor () [0x00000] in <filename unknown>:0

which is still odd, because in the code i didn't attach the monitor,
yet i get this error above when use dotConnect.

Thought?

-tl
tleslie
 
Posts: 2
Joined: Mon 27 Aug 2012 19:31

Re: dbMonitor issue in Pro version (in Mono)

Postby Shalex » Thu 06 Sep 2012 07:33

tleslie wrote:if i change the mono Devart.Data.Mysql dll back to the free one,
its ok, accept I get a
Could not load type 'Devart.Data.MySql.MySqlMonitor' from assembly 'Devart.Data.MySql, Version=7.1.58.0, Culture=neutral, PublicKeyToken=09af7300eec23701'.

This is a designed behaviour. The MySqlMonitor class is not available in the Express edition of dotConnect for MySQL: http://www.devart.com/dotconnect/mysql/editions.html.

tleslie wrote:Then i wanted to do some dbMonitor stuff, and I paid for the Pro version.
System.EntryPointNotFoundException: QueryPerformanceFrequency
at (wrapper managed-to-native) Devart.Common.a0:QueryPerformanceFrequency (long&)
at Devart.Common.a0.b () [0x00000] in <filename unknown>:0
at Devart.Common.a0..cctor () [0x00000] in <filename unknown>:0

We have reproduced the error on Mono when MySqlMonitor.IsActive is set to True. We will investigate the issue and post here about the results.
Shalex
Devart Team
 
Posts: 7608
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for MySQL